Bug 1324 - Download indicator don't changed when install programs
: Download indicator don't changed when install programs
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Low normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-24 16:14 MSK by Vladimir Potapov
Modified: 2013-01-18 11:48 MSK (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments
not (236.39 KB, image/png)
2012-12-24 16:15 MSK, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2012-12-24 16:14:24 MSK
Description of problem:
Download indicator don't changed when install programs
See screenshot
Comment 1 Vladimir Potapov 2012-12-24 16:15:55 MSK
Created attachment 963 [details]
not
Comment 2 Denis Silakov 2013-01-10 16:48:10 MSK
Can't reproduce this inside VM at the moment - download indicator works fine for me...

And what happens next in your situation? Does rpmdrake successfully download and install thunderbird? Since the screenshot looks like the downloaded hasn't been started yet. Traffic displayed in NM (3.77 MB) is very small, maybe it has only downloaded synthesis files and some aux data, but not the package itself at the moment when the screenshot was made?
Comment 3 Vladimir Potapov 2013-01-10 17:49:38 MSK
I see this error in 1/2 installation cases. 
The indicator freeze, but installation work correct.
Comment 4 Denis Silakov 2013-01-10 18:05:06 MSK
Ok. Setting importance to Low, since this doesn't break anything.
Comment 5 mtzseb 2013-01-10 18:27:08 MSK
+1
Comment 6 Denis Silakov 2013-01-15 11:25:52 MSK
Bug #1460 looks similar to this one. In that bug there is a note that everything works fine if wget is used instead of curl.
Comment 7 Denis Silakov 2013-01-15 14:49:57 MSK
The same suggestion as in bug #1460 - try to update curl and libcurl4 to packages from this repo:

(32bit) http://abf.rosalinux.ru/downloads/dsilakov_personal/repository/rosa2012.1/i586/main/release/

(64bit) http://abf.rosalinux.ru/downloads/dsilakov_personal/repository/rosa2012.1/x86_64/main/release/

In parallel, please check if the issue go away if you switch downloader to wget.
Comment 8 Vladimir Potapov 2013-01-16 15:30:07 MSK
Switch downloader to wget solve this problem in all cases.
Comment 9 Vladimir Potapov 2013-01-16 15:31:47 MSK
(In reply to comment #7)
> The same suggestion as in bug #1460 - try to update curl and libcurl4 to
> packages from this repo:
> 
> (32bit)
> http://abf.rosalinux.ru/downloads/dsilakov_personal/repository/rosa2012.1/
> i586/main/release/
> 
> (64bit)
> http://abf.rosalinux.ru/downloads/dsilakov_personal/repository/rosa2012.1/
> x86_64/main/release/
Maybe, rebuild this package for standard QA - in non-personal repos?
Comment 10 Denis Silakov 2013-01-16 15:36:47 MSK
*** Bug 1460 has been marked as a duplicate of this bug. ***
Comment 11 Denis Silakov 2013-01-16 15:39:54 MSK
Actually I am not sure if curl update will fix the issue with rpmdrake progressbar (when using curl downloader), still haven't got enough time for experiments...
Comment 12 FirstLevel 2013-01-16 16:16:20 MSK
(In reply to comment #11)
> Actually I am not sure if curl update will fix the issue with rpmdrake
> progressbar (when using curl downloader), still haven't got enough time for
> experiments...

My user has said that with updated curl the problem was solved.
Comment 13 Denis Silakov 2013-01-17 10:49:11 MSK
Advisory:

Updated curl to a next minor version to fix issues with rpmdrake download progressbar.

Build lists:

https://abf.rosalinux.ru/build_lists/898870
https://abf.rosalinux.ru/build_lists/898869
Comment 14 Vladimir Potapov 2013-01-17 15:14:12 MSK
This update does not fix the error completely, but reduces the frequency of its appearance (only for BIG file).  If there are no other ideas, I can approve the update.
Comment 15 Denis Silakov 2013-01-17 21:52:17 MSK
Well, this seems to be curl bug. If curl update helps at least partially, let's publish it and file another bug (btw, do you have any particular package on which the error is constantly reproduced even with new curl?)
Comment 16 Vladimir Potapov 2013-01-18 07:05:46 MSK
curl-7.28.1-1-rosa2012.1
****************** Advisory ********************
Updated curl to a next minor version to partially fix issues with rpmdrake download progressbar.
************************************************
QA Verified
Comment 17 Alexander Burmashev 2013-01-18 11:48:07 MSK
While curl update fixes the bug please check the whole system stability after the update.
I remember last time we reverted curl update for some reason.
Anyway