Bug 1320 - 2012.1,system requirement warning
: 2012.1,system requirement warning
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Low minor
: ---
Assigned To: Konstantin Vlasov
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-24 15:05 MSK by philippe.roubach
Modified: 2014-10-11 08:00 MSD (History)
6 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description philippe.roubach 2012-12-24 15:05:59 MSK
Description of problem:

during installation at the beggining we have this message :


system requirement warning
recommanded system parameters

RAM = 640 MB
HDD = 10 GB

your system parameters :

your system resources are too low
Comment 1 Alexander Burmashev 2012-12-24 15:06:53 MSK
Do you have  more ram and more place on the HDD ?
Comment 2 philippe.roubach 2012-12-24 15:08:35 MSK
my pc has 8 Go ram
and for the test i allocate 7 G0 for /, 1 Go for swap/, 2Go for /home
Comment 3 philippe.roubach 2012-12-24 15:09:29 MSK
i have same message with virtualbox

with vbox i allocate a 15 Go virtual hdd
Comment 4 Alexander Burmashev 2012-12-24 15:10:08 MSK
I think this may be the problem, installer is setup to handle <10 GB for / as too small partition.
Comment 5 Sylvainsjc 2012-12-24 17:17:30 MSK
(In reply to comment #4)
> I think this may be the problem, installer is setup to handle <10 GB for /
> as too small partition.

This is not a major problem but I can confirm.
I've noticed this behavior on a VirtualBox machine with 15 GB hard drive and 1GB of RAM
I also noticed the same behavior when I installed on my desktop with a 1TB drive and 8GB of RAM
Comment 6 Konstantin Vlasov 2012-12-24 18:35:17 MSK
To everybody who experience this problem: could you please boot into Live system from ROSA DVD, run fdisk -l and post the output here?
Comment 7 philippe.roubach 2012-12-26 13:56:56 MSK
using live dvd, just after kde opening session my pc freezes !

due to "ondemand" cppupower profile

 see http://bugs.rosalinux.ru/show_bug.cgi?id=1303

then i can't run "fdisk -l"
Comment 8 Konstantin Vlasov 2012-12-26 14:51:50 MSK
(In reply to comment #7)
> using live dvd, just after kde opening session my pc freezes !
> 
> due to "ondemand" cppupower profile
> 
>  see http://bugs.rosalinux.ru/show_bug.cgi?id=1303
> 
> then i can't run "fdisk -l"

Well, actually, live session is not needed for this test. Could you please do the following?
1. Boot from ROSA DVD either in Live or in Install mode, until the very first dialog appears (language selection).
2. Wait for several seconds (to be sure TTYs completed initializition), then press Ctrl+Alt+F2.
3. In the terminal screen login as root (password is empty).
4. Run "fdisk -l".

To avoid re-typing everything by hand, you can redirect the output into file:
fdisk -l >/tmp/fdisk.out 2>&1
and then copy the resultant file to another computer (e.g., using scp).
Comment 9 philippe.roubach 2012-12-26 15:02:30 MSK
i have not another pc

how to copy to my hdd ?
Comment 10 Konstantin Vlasov 2012-12-26 15:10:00 MSK
(In reply to comment #9)
> i have not another pc
> 
> how to copy to my hdd ?

# mount /dev/sdX /mnt
# cp /tmp/fdisk.out .ьте
№ umount /mnt

Replace "sdX" with your real HDD partition.
Comment 11 Konstantin Vlasov 2012-12-26 15:11:01 MSK
Sorry, wrong keyboard layout. :-(

# mount /dev/sdX /mnt
# cp /tmp/fdisk.out /mnt
# umount /mnt
Comment 12 philippe.roubach 2012-12-26 15:52:28 MSK
strange result for fdisk -l in fdisk.out

Usage:
 fdisk [options] <disk>    change partition table
 fdisk [options] -l <disk> list partition table(s)
 fdisk -s <partition>      give partition size(s) in blocks

Options:
 -b <size>             sector size (512, 1024, 2048 or 4096)
 -c[=<mode>]           compatible mode: 'dos' or 'nondos' (default)
 -h                    print this help text
 -u[=<unit>]           display units: 'cylinders' or 'sectors' (default)
 -v                    print program version
 -C <number>           specify the number of cylinders
 -H <number>           specify the number of heads
 -S <number>           specify the number of sectors per track
Comment 13 philippe.roubach 2012-12-26 16:08:58 MSK
i retried several times but each time i had a freeze !

is there anyone to do the test with it's pc ?
Comment 14 Sylvainsjc 2012-12-26 17:23:25 MSK
If it can help, here is the result (in the way requested in comment #8) of fdisk on a "ROSA Desktop Fresh" installed in VirtualBox with 25GB hard drive and 1GB memory.

There is also the same messages during installation.


Result of fdisk :
Disk /dev/sda: 26.8 GB, 26843545600 bytes, 52428800 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048    25189919    12593936   83  Linux
/dev/sda2        25192440    52420094    13613827+   5  Extended
/dev/sda5        25192448    28370789     1589171   82  Linux swap / Solaris
/dev/sda6        28372992    52420094    12023551+  83  Linux

Disk /dev/mapper/live-rw: 9114 MB, 9114222592 bytes, 17801216 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Comment 15 Konstantin Vlasov 2012-12-26 20:26:07 MSK
(In reply to comment #12)
> strange result for fdisk -l in fdisk.out

That's strange indeed... Are you sure you didn't make a typo?
Actually, if that's what fdisk displays on your system, it would explain why the installer shows the warning (it parses the fdisk output and calculates HDD size; no HDDs listed - no space available). But I cannot even imagine what could make fdisk fail to recognize its own option... I cannot reproduce it on any of my machines.

If you are sure you typed everything correctly, could you please perform the following experiments? (again, in the same terminal that you get after booting from DVD and going into Ctrl+Alt+F2)

1) What does "parted -l" tell?

2) What is the contents of the file /proc/partitions?

3) Please, start "fdisk /dev/sda" (name your device instead of /dev/sda here); when fdisk prompt appears (telling "Command (m for help):") type "p", <Enter>. Does it print the list of partitions on the hard disk? (To exit fdisk, type "q", <Enter>)

4) What does "fdisk -l /dev/sda" print?



(In reply to comment #14)
> If it can help, here is the result (in the way requested in comment #8) of
> fdisk on a "ROSA Desktop Fresh" installed in VirtualBox with 25GB hard drive
> and 1GB memory.

Did you get this result after booting into your installed system or into the Live system from ROSA DVD? It's important that Live system is used, so that the output of fdisk was totally identical to what installer gets and analyses. (In the installed system the output can be different because of changed partitions, or their labels, or something else.)

And one more questions: Do you get exactly the same message as shown in the first post of the bug report? That is, with just an empty line after "your system parameters:", without specifying what the parameters actually are. Normally, it should add something like: "RAM = 512 Mb", to explain to user what he/she lacks, in particular.
Comment 16 philippe.roubach 2012-12-26 20:35:49 MSK
(In reply to comment #15)
> (In reply to comment #12)
> > strange result for fdisk -l in fdisk.out
> 
> That's strange indeed... Are you sure you didn't make a typo?
> Actually, if that's what fdisk displays on your system, it would explain why
> the installer shows the warning (it parses the fdisk output and calculates
> HDD size; no HDDs listed - no space available). But I cannot even imagine
> what could make fdisk fail to recognize its own option... I cannot reproduce
> it on any of my machines.
> 
> If you are sure you typed everything correctly, could you please perform the
> following experiments? (again, in the same terminal that you get after
> booting from DVD and going into Ctrl+Alt+F2)
> 
> 1) What does "parted -l" tell?
> 
> 2) What is the contents of the file /proc/partitions?
> 
> 3) Please, start "fdisk /dev/sda" (name your device instead of /dev/sda
> here); when fdisk prompt appears (telling "Command (m for help):") type "p",
> <Enter>. Does it print the list of partitions on the hard disk? (To exit
> fdisk, type "q", <Enter>)
> 
> 4) What does "fdisk -l /dev/sda" print?
> 

see my comment #13
Comment 17 Sylvainsjc 2012-12-26 20:58:27 MSK
(In reply to comment #15)
> (In reply to comment #14)
> > If it can help, here is the result (in the way requested in comment #8) of
> > fdisk on a "ROSA Desktop Fresh" installed in VirtualBox with 25GB hard drive
> > and 1GB memory.
> 
> Did you get this result after booting into your installed system or into the
> Live system from ROSA DVD? It's important that Live system is used, so that
> the output of fdisk was totally identical to what installer gets and
> analyses. (In the installed system the output can be different because of
> changed partitions, or their labels, or something else.)
> 
> And one more questions: Do you get exactly the same message as shown in the
> first post of the bug report? That is, with just an empty line after "your
> system parameters:", without specifying what the parameters actually are.
> Normally, it should add something like: "RAM = 512 Mb", to explain to user
> what he/she lacks, in particular.

I get the result after booting the live system from Rosa ISO. I've waited for the select language display and pressed Ctrl+Alt+F2

I confirm that I got exactly the same message as shown in the first post of the bug report: "your system parameters:(empty)" and "your system resources are too low"
Comment 18 Denis Silakov 2013-07-16 11:52:35 MSD
Is this issue valid for Desktop Fresh R1?
Comment 19 Sylvainsjc 2013-07-16 11:55:46 MSD
(In reply to comment #18)
> Is this issue valid for Desktop Fresh R1?

Hi Denis,
Issue is still here with Desktop Fresh R1
Comment 20 Aleksandr Kazantcev 2013-11-08 23:52:38 MSK
If bug still valid?
Comment 21 Sylvainsjc 2013-11-19 22:27:13 MSK
(In reply to comment #20)
> If bug still valid?

Yes still there
Comment 22 FirstLevel 2014-10-08 15:15:17 MSD
Please check the problem for new release
http://mirror.rosalab.ru/rosa/rosa2014.1/iso/ROSA.Fresh.R4/
Comment 23 Sylvainsjc 2014-10-11 00:12:08 MSD
(In reply to comment #22)
> Please check the problem for new release
> http://mirror.rosalab.ru/rosa/rosa2014.1/iso/ROSA.Fresh.R4/

It's ok now with R4. Thanks :)