Bug 1311 - systemctl works incorrectly for udpxy
: systemctl works incorrectly for udpxy
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-24 12:48 MSK by FirstLevel
Modified: 2014-06-03 16:16 MSD (History)
3 users (show)

See Also:
RPM Package: udpxy-1.0.19-0-rosa2012.1.i586.rpm
ISO-related:
Bad POT generating:
Upstream:


Attachments
cat /etc/rc.d/init.d/udpxy (1.79 KB, text/plain)
2012-12-24 12:54 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-12-24 12:48:20 MSK
Description of problem:
I have installed udpxy-1.0.19-0-rosa2012.1.i586.rpm.
If I restart tis service it hangs and could not be restarted.

Restart longs much time:

# /etc/init.d/udpxy restart
Restarting udpxy (via systemctl):  Job for udpxy.service failed. See 'systemctl status udpxy.service' and 'journalctl' for details.
                                                                                                            [FAILED]

When restart is hanging I see:
$ ps ax|grep udp
25078 pts/7    S+     0:00 /bin/bash /etc/init.d/udpxy restart
25093 pts/7    S+     0:00 /bin/systemctl restart udpxy.service
25108 ?        S      0:00 udpxy -S -p 4022 -M 30 -B 1Mb


After [FAILED] I see
$ ps ax|grep udp
25108 ?        S      0:00 udpxy -S -p 4022 -M 30 -B 1Mb
25319 ?        S      0:00 udpxy -S -p 4022 -M 30 -B 1Mb

In /var/log/messages at that moment I see:
Dec 24 16:41:40 localhost systemd[1]: Starting LSB: start and stop udpxy daemon...
Dec 24 16:41:40 localhost udpxy[2993]: udpxy 1.0-Chipmunk (build 19) standard is starting
Dec 24 16:41:41 localhost udpxy[2982]: Starting udpxy daemon[  OK  ]#015[  OK  ]
Dec 24 16:41:41 localhost systemd[1]: PID file /var/run/udpxy.pid not readable (yet?) after start.
Dec 24 16:44:17 localhost systemd[1]: Starting Cleanup of Temporary Directories...
Dec 24 16:44:17 localhost systemd[1]: Started Cleanup of Temporary Directories.
Dec 24 16:46:40 localhost systemd[1]: udpxy.service operation timed out. Terminating.
Dec 24 16:46:40 localhost systemd[1]: Failed to start LSB: start and stop udpxy daemon.
Dec 24 16:46:40 localhost systemd[1]: Unit udpxy.service entered failed state.
^C


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-12-24 12:53:51 MSK
# cat /etc/sysconfig/udpxy 
# Options for udpxy
OPTIONS="-S -p 4022 -M 30 -B 1Mb"
Comment 2 FirstLevel 2012-12-24 12:54:46 MSK
Created attachment 958 [details]
cat /etc/rc.d/init.d/udpxy
Comment 3 Alexander Khryukin 2012-12-24 14:02:06 MSK
Hi.
I need

systemctl status udpxy.service
and journalctl

I think that issue in /var/run directory.
Comment 4 FirstLevel 2012-12-25 08:58:36 MSK
(In reply to comment #3)
> Hi.
> I need
> 
> systemctl status udpxy.service
> and journalctl
> 
> I think that issue in /var/run directory.

# systemctl status udpxy.service
udpxy.service - LSB: start and stop udpxy daemon
          Loaded: loaded (/etc/rc.d/init.d/udpxy)
          Active: failed (Result: timeout) since Sun, 23 Dec 2012 22:39:19 +1000; 24h ago
         Process: 26456 ExecStart=/etc/rc.d/init.d/udpxy start (code=exited, status=0/SUCCESS)
          CGroup: name=systemd:/system/udpxy.service
                  └ 26467 udpxy -S -p 4022 -M 30 -B 1Mb

Dec 23 22:34:19 localhost.localdomain systemd[1]: Starting LSB: start and stop udpxy daemon...
Dec 23 22:34:19 localhost.localdomain udpxy[26467]: udpxy 1.0-Chipmunk (build 19) standard is starting
[  OK  ]2:34:21 localhost.localdomain udpxy[26456]: Starting udpxy daemon[  OK  ]
Dec 23 22:39:19 localhost.localdomain systemd[1]: Failed to start LSB: start and stop udpxy daemon.


# journalctl | grep udpxy
Dec 23 20:54:09 localhost.localdomain urpmi[25032]: called with: udpxy
Dec 23 20:54:30 localhost.localdomain udpxy[25108]: udpxy 1.0-Chipmunk (build...
Dec 23 20:54:31 localhost.localdomain udpxy[25095]: [38B blob data]
Dec 23 20:54:31 localhost.localdomain systemd[1]: PID file /var/run/udpxy.pid...
Dec 23 20:56:18 localhost.localdomain udpxy[25118]: read_buf: read: Resource ...
Dec 23 20:56:23 localhost.localdomain udpxy[25119]: read_buf: read: Resource ...
Dec 23 20:56:48 localhost.localdomain udpxy[25121]: read_buf: read: Resource ...
Dec 23 20:56:54 localhost.localdomain udpxy[25124]: read_buf: read: Resource ...
Dec 23 20:57:08 localhost.localdomain udpxy[25125]: read_buf: read: Resource ...
Dec 23 20:57:14 localhost.localdomain udpxy[25126]: read_buf: read: Resource ...
Dec 23 20:59:29 localhost.localdomain systemd[1]: udpxy.service operation tim...
Dec 23 20:59:29 localhost.localdomain systemd[1]: Unit udpxy.service entered ...
Dec 23 21:01:24 localhost.localdomain udpxy[25319]: read_buf: read: Resource ...
Dec 23 21:01:29 localhost.localdomain udpxy[25322]: read_buf: read: Resource ...
Dec 23 21:02:27 localhost.localdomain udpxy[25345]: read_buf: read: Resource ...
Dec 23 21:02:32 localhost.localdomain udpxy[25346]: read_buf: read: Resource ...
Dec 23 21:02:50 localhost.localdomain udpxy[25108]: udpxy 1.0-Chipmunk (build...
Dec 23 21:02:57 localhost.localdomain udpxy[25352]: udpxy 1.0-Chipmunk (build...
Dec 23 21:03:05 localhost.localdomain udpxy[25353]: read_buf: read: Resource ...
Dec 23 21:03:10 localhost.localdomain udpxy[25354]: read_buf: read: Resource ...
Dec 23 21:03:43 localhost.localdomain udpxy[25352]: udpxy 1.0-Chipmunk (build...
Dec 23 21:03:49 localhost.localdomain udpxy[25367]: udpxy 1.0-Chipmunk (build...
Dec 23 21:03:57 localhost.localdomain udpxy[25368]: read_buf: read: Resource ...
Dec 23 21:04:02 localhost.localdomain udpxy[25371]: read_buf: read: Resource ...
Dec 23 21:04:04 localhost.localdomain udpxy[25367]: udpxy 1.0-Chipmunk (build...
Dec 23 21:05:22 localhost.localdomain udpxy[25395]: udpxy 1.0-Chipmunk (build...
Dec 23 21:05:29 localhost.localdomain udpxy[25396]: read_buf: read: Resource ...
Dec 23 21:05:34 localhost.localdomain udpxy[25397]: read_buf: read: Resource ...
Dec 23 21:05:35 localhost.localdomain udpxy[25395]: udpxy 1.0-Chipmunk (build...
Dec 23 21:05:54 localhost.localdomain udpxy[25399]: udpxy 1.0-Chipmunk (build...
Dec 23 21:06:02 localhost.localdomain udpxy[25400]: read_buf: read: Resource ...
Dec 23 21:06:07 localhost.localdomain udpxy[25401]: read_buf: read: Resource ...
Dec 23 21:06:08 localhost.localdomain udpxy[25399]: udpxy 1.0-Chipmunk (build...
Dec 23 22:34:19 localhost.localdomain udpxy[26467]: udpxy 1.0-Chipmunk (build...
Dec 23 22:34:21 localhost.localdomain udpxy[26456]: [38B blob data]
Dec 23 22:34:21 localhost.localdomain systemd[1]: PID file /var/run/udpxy.pid...
Dec 23 22:39:19 localhost.localdomain systemd[1]: udpxy.service operation tim...
Dec 23 22:39:19 localhost.localdomain systemd[1]: Unit udpxy.service entered ...
Dec 23 22:42:15 localhost.localdomain udpxy[26837]: read_buf: read: Resource ...
Dec 23 22:42:15 localhost.localdomain udpxy[26838]: read_buf: read: Resource ...
Dec 23 22:42:20 localhost.localdomain udpxy[26836]: write_buf: write: Connect...
Comment 5 FirstLevel 2014-06-03 16:08:57 MSD
checking the relevance