Bug 1308 - ROSA 2012.1 Desktop Fresh (32bit ) could not see 4GB of RAM
: ROSA 2012.1 Desktop Fresh (32bit ) could not see 4GB of RAM
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-24 09:49 MSK by FirstLevel
Modified: 2012-12-24 14:45 MSK (History)
4 users (show)

See Also:
RPM Package: 3.6.10-nrj-desktop-1rosa
ISO-related:
Bad POT generating:
Upstream:


Attachments
32 bit system (20.50 KB, text/plain)
2012-12-24 09:49 MSK, FirstLevel
Details
64 bit system (20.66 KB, text/plain)
2012-12-24 09:49 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-12-24 09:49:00 MSK
Created attachment 954 [details]
32 bit system

Description of problem:
I have ROSA 2012.1 Desktop Fresh (i586 ) installed on my laptop Samsung 355V5X-S01
with 4GB of RAM. Laptop has two GPU AMD and I use dicrete.
[serge@localhost ~]$ uname -a
Linux localhost.localdomain 3.6.10-nrj-desktop-1rosa #1 SMP PREEMPT Wed Dec 12 13:57:22 UTC 2012 i686 i686 i686 GNU/Linux
But system can see only 2 GB of RAM.
I have attached diagnostic information from installed 32bit system and from live 64bit system.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-12-24 09:49:14 MSK
Created attachment 955 [details]
64 bit system
Comment 2 Aleksandr Kazantcev 2012-12-24 12:58:19 MSK
For 32-bit install PAE kernel.

Standard i586 kernel may see from 2 to 3 Gb RAM related to chipset and CPU.
4GB RAM is not possible anymore - it's error in description...
Comment 3 Alexander Burmashev 2012-12-24 13:10:11 MSK
To test PAE kernel use this personal repo for now
http://abf.rosalinux.ru/downloads/rosa2012.1/container/Kernel-3.6.10-1-856191/RPMS/
Comment 4 FirstLevel 2012-12-24 14:00:56 MSK
(In reply to comment #2)
> For 32-bit install PAE kernel.
> 
> Standard i586 kernel may see from 2 to 3 Gb RAM related to chipset and CPU.
> 4GB RAM is not possible anymore - it's error in description...

Do You mean that standard kernel is build without PAE?
Comment 5 Alexander Burmashev 2012-12-24 14:03:37 MSK
yes, PAE can't be enabled as a default feature because there are still some users with CPUs that do not support PAE at all.
Users with non-PAE kernels can install PAE easily, but users who do not have PAE support simply can't even start the boot.
Comment 6 FirstLevel 2012-12-24 14:11:09 MSK
(In reply to comment #5)
> yes, PAE can't be enabled as a default feature because there are still some
> users with CPUs that do not support PAE at all.
> Users with non-PAE kernels can install PAE easily, but users who do not have
> PAE support simply can't even start the boot.

But I can not find PAE kernel in oficial repos. Or do we have only experimental kernel in http://abf.rosalinux.ru/downloads/rosa2012.1/container/Kernel-3.6.10-1-856191/RPMS/ ?
Comment 7 Denis Koryavov 2012-12-24 14:26:46 MSK
PAE kernel is a "hack". Even in MS Windows PAE was forcedly disabled, because of many problems with this. For example: http://bugs.rosalinux.ru/show_bug.cgi?id=217
Comment 8 Alexander Burmashev 2012-12-24 14:28:12 MSK
(In reply to comment #6)
> (In reply to comment #5)
> > yes, PAE can't be enabled as a default feature because there are still some
> > users with CPUs that do not support PAE at all.
> > Users with non-PAE kernels can install PAE easily, but users who do not have
> > PAE support simply can't even start the boot.
> 
> But I can not find PAE kernel in oficial repos. Or do we have only
> experimental kernel in
> http://abf.rosalinux.ru/downloads/rosa2012.1/container/Kernel-3.6.10-1-
> 856191/RPMS/ ?

I forgot to build it to the main/release, publish request to publish the PAE kernel to the official repo is already done. It will be in the repository soon.
Comment 9 FirstLevel 2012-12-24 14:30:39 MSK
(In reply to comment #8)
> (In reply to comment #6)
> > (In reply to comment #5)
> > > yes, PAE can't be enabled as a default feature because there are still some
> > > users with CPUs that do not support PAE at all.
> > > Users with non-PAE kernels can install PAE easily, but users who do not have
> > > PAE support simply can't even start the boot.
> > 
> > But I can not find PAE kernel in oficial repos. Or do we have only
> > experimental kernel in
> > http://abf.rosalinux.ru/downloads/rosa2012.1/container/Kernel-3.6.10-1-
> > 856191/RPMS/ ?
> 
> I forgot to build it to the main/release, publish request to publish the PAE
> kernel to the official repo is already done. It will be in the repository
> soon.

How should users know that new pae kernel is present in repo?
May You inform me about name of this package?
Comment 10 Alexander Burmashev 2012-12-24 14:40:46 MSK
Name of the kernel is kernel-nrj-desktop-pae.
Comment 11 FirstLevel 2012-12-24 14:45:13 MSK
(In reply to comment #10)
> Name of the kernel is kernel-nrj-desktop-pae.

Thanks. We are waiting