Bug 1306 - 2012.1,Failed to start Cleanup of Temporary Directories.
: 2012.1,Failed to start Cleanup of Temporary Directories.
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-23 18:14 MSK by philippe.roubach
Modified: 2013-11-18 11:08 MSK (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description philippe.roubach 2012-12-23 18:14:44 MSK
Description of problem:


in /var/messages there is

Dec 23 15:03:53 localhost systemd[1]: Failed to start Cleanup of Temporary Directories.
Comment 1 Denis Silakov 2012-12-25 11:29:06 MSK
Are you able to manually start:

systemdtmpfiles --clean

?
Comment 2 philippe.roubach 2012-12-26 12:48:04 MSK
[root@localhost ~]# systemdtmpfiles --clean
-bash: systemdtmpfiles : commande introuvable
[root@localhost ~]#
Comment 3 Denis Silakov 2012-12-26 21:00:34 MSK
Sorry, I've missed a hyphen in the command name:

systemd-tmpfiles --clean
Comment 4 philippe.roubach 2012-12-27 15:59:25 MSK
[root@localhost ~]# systemd-tmpfiles --clean
[/usr/lib/tmpfiles.d/legacy.conf:22] Unknown group 'lock'.
stat(/run/user/500/gvfs) failed: Permission denied
[root@localhost ~]#
Comment 5 Alexander Burmashev 2012-12-27 16:00:07 MSK
try please
 urpmi --replacepkg lockdev
and then one more time 
 systemd-tmpfiles --clean
Comment 6 philippe.roubach 2012-12-27 16:27:52 MSK
[root@localhost ~]# urpmi --replacepkg lockdev


    $MIRRORLIST: media/main/release/lockdev-1.0.4-0.120111007git.6-rosa2012.1.x86_64.rpm
installation de lockdev-1.0.4-0.120111007git.6-rosa2012.1.x86_64.rpm depuis /var/cache/urpmi/rpms
Préparation ...                  #############################################
      1/1: lockdev               #############################################
[root@localhost ~]# systemd-tmpfiles --clean
[root@localhost ~]#
Comment 7 Alexander Burmashev 2012-12-27 16:28:54 MSK
So it seem that failed lockdev installed during the iso build causes this bug.
Can you please try to reboot and check if the error is gone, or next time when you will be rebooting check it please.
Comment 8 philippe.roubach 2012-12-27 16:56:30 MSK
next reboot

[root@localhost ~]# systemd-tmpfiles --clean
[root@localhost ~]#
Comment 9 philippe.roubach 2012-12-27 17:04:46 MSK
>> So it seem that failed lockdev installed during the iso build causes this bug.

i use live dvd to install rosa desktop fresh 2012
Comment 10 Alexander Burmashev 2012-12-27 17:07:23 MSK
I know, but lockdev was already broken at that moment :)
Comment 11 philippe.roubach 2012-12-27 21:44:47 MSK
sorry the comment #6 is with vbox
with a real pc

[root@localhost ~]# urpmi --replacepkg lockdev


    $MIRRORLIST: media/main/release/lockdev-1.0.4-0.120111007git.6-rosa2012.1.x86_64.rpm
installation de lockdev-1.0.4-0.120111007git.6-rosa2012.1.x86_64.rpm depuis /var/cache/urpmi/rpms
Préparation ...                  #############################################
      1/1: lockdev               #############################################
[root@localhost ~]# systemd-tmpfiles --clean
stat(/run/user/500/gvfs) failed: Permission denied
[root@localhost ~]#
Comment 12 Alexander Burmashev 2012-12-28 15:31:04 MSK
Spent some time investigating the issue and i guess it may be a wontfix


https://bugzilla.gnome.org/show_bug.cgi?id=560658
https://bugs.launchpad.net/gvfs/+bug/225361
https://bugs.archlinux.org/task/32715


Still looking for a fix, not a workaround
Comment 13 Postnikov Dmitry 2013-07-02 15:50:34 MSD
Similar problems in ROSA FRESH GMOME R1 (RC2)
===========
localhost	systemd[1]	Starting Recreate Volatile Files and Directories...
localhost	systemd-tmpfiles[7749]	[/usr/lib/tmpfiles.d/legacy.conf:22] Unknown group 'lock'.
localhost	systemd-tmpfiles[7749]	readlink(/run/resolvconf/resolv.conf) failed: Invalid argument
localhost	systemd[1]	systemd-tmpfiles-setup.service: main process exited, code=exited, status=1
localhost	systemd[1]	Failed to start Recreate Volatile Files and Directories.
ocalhost	systemd[1]	Unit systemd-tmpfiles-setup.service entered failed state.
===========
Comment 14 Aleksandr Kazantcev 2013-11-08 23:50:43 MSK
If bug still valid?
Comment 15 Postnikov Dmitry 2013-11-10 18:53:44 MSK
(In reply to comment #14)
> If bug still valid?

Yes problem is only present in the Gnome version. (iso 1862)

=======
[root@mindlife pastordi]# cat /var/log/messages | grep -i tmp
[root@mindlife pastordi]# 
[root@mindlife pastordi]# cat /var/log/syslog | grep -i tmp
[root@mindlife pastordi]# 
[root@mindlife pastordi]# systemd-tmpfiles --clean
stat(/run/user/500/gvfs) failed: Permission denied
[root@mindlife pastordi]# 
========
Comment 16 Aleksandr Kazantcev 2013-11-10 19:35:21 MSK
I see no errors. Gvfs may nit clean - thus is not a bug, because root may not touch user gvfs link.
Comment 17 Postnikov Dmitry 2013-11-10 19:37:52 MSK
From user:

===========
[pastordi@mindlife ~]$ systemd-tmpfiles --clean
opendir(/var/cache/man/ms) failed: Operation not permitted
opendir(/var/cache/man/bg) failed: Operation not permitted
opendir(/var/cache/man/pt) failed: Operation not permitted
opendir(/var/cache/man/cs) failed: Operation not permitted
opendir(/var/cache/man/si) failed: Operation not permitted
opendir(/var/cache/man/eu) failed: Operation not permitted
opendir(/var/cache/man/cat1) failed: Operation not permitted
opendir(/var/cache/man/zh_CN) failed: Operation not permitted
opendir(/var/cache/man/ru.KOI8-R) failed: Operation not permitted
opendir(/var/cache/man/es) failed: Operation not permitted
opendir(/var/cache/man/cat2) failed: Operation not permitted
opendir(/var/cache/man/cat6) failed: Operation not permitted
opendir(/var/cache/man/cy) failed: Operation not permitted
opendir(/var/cache/man/fa) failed: Operation not permitted
opendir(/var/cache/man/ml) failed: Operation not permitted
opendir(/var/cache/man/ru.UTF-8) failed: Operation not permitted
opendir(/var/cache/man/pt_PT) failed: Operation not permitted
opendir(/var/cache/man/nb) failed: Operation not permitted
opendir(/var/cache/man/it.UTF-8) failed: Operation not permitted
opendir(/var/cache/man/he) failed: Operation not permitted
opendir(/var/cache/man/it.ISO8859-1) failed: Operation not permitted
opendir(/var/cache/man/et) failed: Operation not permitted
opendir(/var/cache/man/bo) failed: Operation not permitted
opendir(/var/cache/man/shn) failed: Operation not permitted
opendir(/var/cache/man/sv) failed: Operation not permitted
opendir(/var/cache/man/ko) failed: Operation not permitted
opendir(/var/cache/man/it) failed: Operation not permitted
opendir(/var/cache/man/zh) failed: Operation not permitted
opendir(/var/cache/man/ast) failed: Operation not permitted
opendir(/var/cache/man/jp) failed: Operation not permitted
opendir(/var/cache/man/ro) failed: Operation not permitted
opendir(/var/cache/man/pl.UTF-8) failed: Operation not permitted
opendir(/var/cache/man/sq) failed: Operation not permitted
opendir(/var/cache/man/ps) failed: Operation not permitted
opendir(/var/cache/man/lt) failed: Operation not permitted
opendir(/var/cache/man/cat8) failed: Operation not permitted
opendir(/var/cache/man/gd) failed: Operation not permitted
opendir(/var/cache/man/pa) failed: Operation not permitted
opendir(/var/cache/man/ru) failed: Operation not permitted
opendir(/var/cache/man/el) failed: Operation not permitted
opendir(/var/cache/man/cat4) failed: Operation not permitted
opendir(/var/cache/man/id) failed: Operation not permitted
opendir(/var/cache/man/hi) failed: Operation not permitted
opendir(/var/cache/man/eo) failed: Operation not permitted
opendir(/var/cache/man/ja) failed: Operation not permitted
opendir(/var/cache/man/pt_BR) failed: Operation not permitted
opendir(/var/cache/man/tr) failed: Operation not permitted
opendir(/var/cache/man/bn) failed: Operation not permitted
opendir(/var/cache/man/hu) failed: Operation not permitted
opendir(/var/cache/man/fr.ISO8859-1) failed: Operation not permitted
opendir(/var/cache/man/io) failed: Operation not permitted
opendir(/var/cache/man/ta) failed: Operation not permitted
opendir(/var/cache/man/cat3) failed: Operation not permitted
opendir(/var/cache/man/de) failed: Operation not permitted
opendir(/var/cache/man/fy) failed: Operation not permitted
opendir(/var/cache/man/ca@valencia) failed: Operation not permitted
opendir(/var/cache/man/ug) failed: Operation not permitted
opendir(/var/cache/man/nl) failed: Operation not permitted
opendir(/var/cache/man/nn) failed: Operation not permitted
opendir(/var/cache/man/ar) failed: Operation not permitted
opendir(/var/cache/man/en_GB) failed: Operation not permitted
opendir(/var/cache/man/hr) failed: Operation not permitted
opendir(/var/cache/man/my) failed: Operation not permitted
opendir(/var/cache/man/lv) failed: Operation not permitted
opendir(/var/cache/man/fr) failed: Operation not permitted
opendir(/var/cache/man/cat5) failed: Operation not permitted
opendir(/var/cache/man/sr) failed: Operation not permitted
opendir(/var/cache/man/th) failed: Operation not permitted
opendir(/var/cache/man/sk) failed: Operation not permitted
opendir(/var/cache/man/te) failed: Operation not permitted
opendir(/var/cache/man/zh_TW) failed: Operation not permitted
opendir(/var/cache/man/pl) failed: Operation not permitted
opendir(/var/cache/man/local) failed: Operation not permitted
opendir(/var/cache/man/zh_HK) failed: Operation not permitted
opendir(/var/cache/man/pl.ISO8859-2) failed: Operation not permitted
opendir(/var/cache/man/en_AU) failed: Operation not permitted
opendir(/var/cache/man/fi) failed: Operation not permitted
opendir(/var/cache/man/fo) failed: Operation not permitted
opendir(/var/cache/man/ca) failed: Operation not permitted
opendir(/var/cache/man/sl) failed: Operation not permitted
opendir(/var/cache/man/be) failed: Operation not permitted
opendir(/var/cache/man/oc) failed: Operation not permitted
opendir(/var/cache/man/cat7) failed: Operation not permitted
opendir(/var/cache/man/fr.UTF-8) failed: Operation not permitted
opendir(/var/cache/man/uk) failed: Operation not permitted
opendir(/var/cache/man/ku) failed: Operation not permitted
opendir(/var/cache/man/da) failed: Operation not permitted
opendir(/var/cache/man/cat9) failed: Operation not permitted
opendir(/var/cache/man/kk) failed: Operation not permitted
opendir(/var/cache/man/km) failed: Operation not permitted
opendir(/var/cache/man/gl) failed: Operation not permitted
opendir(/var/cache/man/vi) failed: Operation not permitted
opendir(/var/cache/man/uz) failed: Operation not permitted
opendir(/var/cache/man/bs) failed: Operation not permitted
[pastordi@mindlife ~]$
========
Comment 18 Alexander Burmashev 2013-11-10 20:44:30 MSK
tmpfiles.d shoudl be cleaned from root
Comment 19 Denis Silakov 2013-11-18 11:08:25 MSK
The initial issue discussed in this bug ("Failed to start Cleanup of Temporary Directories") has been fixed, and "systemd-tmpfiles --clean" works fine from root.