Bug 1303 - 2012.1, system freeze or reboot with "ondemand" profile
: 2012.1, system freeze or reboot with "ondemand" profile
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-22 18:38 MSK by philippe.roubach
Modified: 2014-10-10 13:06 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description philippe.roubach 2012-12-22 18:38:06 MSK
Description of problem:


by default the installer set cpupower to "ondemand" profile.

this freezes somme pc as mine during filling kdm template or kde session after a brief time
or
this causes reboot during boot or during kde session !

to be compatible to every pc mease set "performance" profile by default

if you have chance to open a kde session you have no time to change cpupower file !

i must launch another system to change the statement in /etc/sysconfig/cpupower file

or give the choice during rosa installation

and it's hard for a non techie to guess it is a cpu frequence management pb and more hard to find what file and what statement to change !
Comment 1 Aleksandr Kazantcev 2012-12-22 19:02:44 MSK
More users has NOT problem with ondemadn, but has problem (especially in notebooks) with overhead it's system. Modern CPU has energysaving technolodgi also in desktop. We enable ONDEMAND in that reason... But you may

1. Add 's' or '1' or 'single' in grub boot line (press E, find string with "splash=silent" than add this (without quotes) for the end, than press F10 to boot
2. Login as root
3. Run mc and edit file cat /etc/sysconfig/cpupower and uncomment lines

# CPUPOWER_START_OPTS="frequency-set -g performance" and # CPUPOWER_STOP_OPTS="frequency-set -g ondemand"

Reboot and profit...
Comment 2 philippe.roubach 2012-12-22 21:14:31 MSK
>> Modern CPU has energysaving technolodgi also in desktop. We enable ONDEMAND in that reason.

i agree with you
me i know how to fix the pb
but what a non techie person does in this case ?

>> 3. Run mc and edit file cat /etc/sysconfig/cpupower and uncomment lines

>> # CPUPOWER_START_OPTS="frequency-set -g performance" and #
>> CPUPOWER_STOP_OPTS="frequency-set -g ondemand"

do you know the exact meaning of CPUPOWER_START_OPTS and CPUPOWER_STOP_OPTS
Comment 3 Aleksandr Kazantcev 2012-12-22 21:42:30 MSK
How many persons with this error?

When we tested this purposes negative was been huge less than positive... 

But.. We may change this for current CPU model but need сpuinfo for this...

What CPU has a problem. May you get me

 cat /proc/cpuinfo

problem processors?
Comment 4 philippe.roubach 2012-12-22 22:10:23 MSK
[root@localhost ~]# cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 107
model name      : AMD Athlon(tm) 64 X2 Dual Core Processor 5000+
stepping        : 2
cpu MHz         : 1800.000
cache size      : 512 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
apicid          : 0
initial apicid  : 0
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch lbrv
bogomips        : 3616.53
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps

processor       : 1
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 107
model name      : AMD Athlon(tm) 64 X2 Dual Core Processor 5000+
stepping        : 2
cpu MHz         : 1800.000
cache size      : 512 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
apicid          : 1
initial apicid  : 1
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch lbrv
bogomips        : 3616.53
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps

[root@localhost ~]#
Comment 5 philippe.roubach 2012-12-22 22:13:50 MSK
the available freqsuencies for my cpu :2.60 GHz, 2.40 GHz, 2.20 GHz, 2.00 GHz, 1.80 GHz, 1000 MHz

my cpu works with "ondemand" profile only if we forbid the slowest frequency (1000 MHz)
Comment 6 Aleksandr Kazantcev 2012-12-23 19:07:03 MSK
Very strange... It is working ONDEMAND CPU. May be combination of motherboard and CPU give this error, because governors providing by CPU themself and fot this CPU working limits are 1000 MHz - 2.60 GHz

Use workaround with edit cpupower config or try install powernowd utilite...
Comment 7 philippe.roubach 2012-12-23 19:27:21 MSK
i don't know cpupower

with mandriva 2010.2 i586 i use laptop-mode

with laptop-mode i can forbid a cpu frequency
Comment 8 Aleksandr Kazantcev 2012-12-23 21:22:50 MSK
cpupower is governor instruments deepy implimenting in kernel via 3.5 version... In kernel 3.8 for example will able fully disable CPU kernels via this.

For that reason we don't drop cpupower service and config for it - more simple uncomment some line in config.

Idea with setup CPUPOWER state in install mode is more good and i'm think we discuss about realisation (if you see we add some old idea for setup service in install).
Comment 9 philippe.roubach 2012-12-26 13:41:37 MSK
today also i discovered  that i can't use the live version because after a while it freezes !
Comment 10 Aleksandr Kazantcev 2013-11-08 23:50:21 MSK
If bug still valid?
Comment 11 Eugene Shatokhin 2014-10-10 13:06:50 MSD
We could not reproduce the problem and there was no response from the user for several months, so I'll close this bug. 

Please reopen if the problem shows up in ROSA Fresh R4.