Bug 1299 - 2012.1: bluetooth does not work
: 2012.1: bluetooth does not work
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-22 16:49 MSK by philippe.roubach
Modified: 2015-04-01 15:38 MSD (History)
5 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description philippe.roubach 2012-12-22 16:49:28 MSK
Description of problem:

bluedevil says "bluetooth is activated" but my adapter does not blink(<=> it is off)

if you try to unactivate bluetooth using bluedevil option "unactivate bluetooth" then nothing happens. bledevil keeps on saying "bluettoh activated"
Comment 1 Alexander Burmashev 2012-12-22 16:50:22 MSK
Hi, can you please run 
systemctl status bluetooth 
?
Comment 2 philippe.roubach 2012-12-22 17:16:27 MSK
i encounter this pb with mandriva 2010.2 with kernel >= 3.2

i solved this pb.

how ? by updating to last version all bluetooth suite : bluez, bluedevil, openobex, obexftp ...

i will send you report of "systemctl status bluetooth" but i must restart my pc with rosa
Comment 3 philippe.roubach 2012-12-22 17:55:58 MSK
[root@localhost ~]# systemctl status bluetooth
bluetooth.service - Bluetooth Manager
          Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled)
          Active: active (running) since Sat, 22 Dec 2012 14:45:21 +0100; 10min ago
        Main PID: 1632 (bluetoothd)
          CGroup: name=systemd:/system/bluetooth.service
                  └ 1632 /usr/sbin/bluetoothd -n

Dec 22 14:45:21 localhost.localdomain bluetoothd[1632]: bluetoothd[1632]: Adapter /org/bluez/1632/hci0 has been enabled
Dec 22 14:45:21 localhost.localdomain bluetoothd[1632]: Adapter /org/bluez/1632/hci0 has been enabled
Dec 22 14:45:21 localhost.localdomain bluetoothd[1632]: bluetoothd[1632]: hci0: Get Connections (0x0015) failed: Not Powered (0x0f)
Dec 22 14:45:21 localhost.localdomain bluetoothd[1632]: hci0: Get Connections (0x0015) failed: Not Powered (0x0f)
Dec 22 14:46:13 localhost.localdomain bluetoothd[1632]: bluetoothd[1632]: Endpoint registered: sender=:1.53 path=/MediaEndpoint/HFPAG
Dec 22 14:46:13 localhost.localdomain bluetoothd[1632]: Endpoint registered: sender=:1.53 path=/MediaEndpoint/HFPAG
Dec 22 14:46:13 localhost.localdomain bluetoothd[1632]: Endpoint registered: sender=:1.53 path=/MediaEndpoint/HFPHS
Dec 22 14:46:13 localhost.localdomain bluetoothd[1632]: Endpoint registered: sender=:1.53 path=/MediaEndpoint/A2DPSource
Dec 22 14:46:13 localhost.localdomain bluetoothd[1632]: bluetoothd[1632]: Endpoint registered: sender=:1.53 path=/MediaEndpoint/HFPHS
Dec 22 14:46:13 localhost.localdomain bluetoothd[1632]: bluetoothd[1632]: Endpoint registered: sender=:1.53 path=/MediaEndpoint/A2DPSource
[root@localhost ~]#
Comment 4 philippe.roubach 2012-12-26 13:25:36 MSK
today there was update about bluedevil, openobex, obexftp but bluetooth still does not work. same as in "description"

bluetooth daemon is well activated at boot up


Is it normal the following packets 

lib64openobex1 1.5
lib64openobex2 1.6

are all the 2 installed ?

i see that bluedevil 1.2.4 is installed

i use bluedevil 1.3 rc without any pb with my mandriva 2010.2 i586
Comment 5 philippe.roubach 2012-12-26 14:16:02 MSK
compared to my mandriva 2010.2 i586
 i use more recent :
- bluedevil 1.3 rc2
- obexd 0.47

perhaps it is the pb with rosa 2012.1 ?
Comment 6 philippe.roubach 2013-01-06 14:34:03 MSK
during boot up i have these error messages :

Jan  6 11:22:44 localhost bluetoothd[1236]: bluetoothd[1236]: hci0: Set Powered (0x0005) failed: Busy (0x0a)
Jan  6 11:22:44 localhost bluetoothd[1236]: hci0: Set Powered (0x0005) failed: Busy (0x0a)
Comment 7 philippe.roubach 2013-01-10 17:43:36 MSK
i made this experiment

i install again rosa
Comment 8 philippe.roubach 2013-01-10 17:46:31 MSK
i made this experiment

i install again rosa
then
i restart
then
bluetooth dongle is blinking, bluedevil in in the state "activated", i can unactivate bluedevil

then
i update rosa
then
i restart
then
bluetooth dongle is not blinking, bluedevil in in the state "activated", i can't unactivate bluedevil
Comment 9 Alexander Khryukin 2013-01-10 17:54:51 MSK
Hi.
Show output of
rpm -qa | grep -i obex
Comment 10 philippe.roubach 2013-01-10 18:17:50 MSK
[root@localhost ~]# rpm -qa | grep -i obex
lib64openobex1-1.5-8-rosa2012.1.x86_64
obexd-0.46-1-rosa2012.1.x86_64
lib64openobex2-1.6-1-rosa2012.1.x86_64
lib64obexftp0-0.23-9-rosa2012.1.x86_64
obexftp-0.23-9-rosa2012.1.x86_64
obex-data-server-0.4.6-5-rosa2012.1.x86_64
[root@localhost ~]#
Comment 11 philippe.roubach 2013-01-14 19:11:12 MSK
ignore comment #8

i made this experiment

i install again rosa
then
i restart
then
bluetooth dongle is blinking, bluedevil in in the state "activated", i can unactivate bluedevil

then
i restart
then
bluetooth dongle is not blinking, bluedevil is in the state "activated", i can't unactivate bluedevil

it is not a pb about updating. the pb comes without any updating from the begining
Comment 12 philippe.roubach 2013-09-29 17:27:02 MSD
today i re-install rosa fresh desktop r1 with all updates .

results :

- at startup dongle is not activated
- i can activate the dongle with

hcicongi hc0 down
hcicongi hc0 up

once the dongle is activated :

- with bluedevil i ask to unactivate bluetooth then bluedevil indicates "bluetooth is unactive" but the dongle stays active

- all bluetooth features works well : pairing , send , copy , explore

i tested last bluedevil 1.3.2 and lib64bluedevil 1.9.4 from abf

it is worst : when asking to bluedevil to unactivate bluetooth then bluedevil crashes and disapears
the sole way to have again bluedevil working is to restart pc
Comment 13 FirstLevel 2014-10-08 15:01:37 MSD
Please check the problem for new release
http://mirror.rosalab.ru/rosa/rosa2014.1/iso/ROSA.Fresh.R4/
Comment 14 Denis Silakov 2015-03-29 16:07:18 MSD
Let's mark as "worksforme" since we haven't see a way to reproduce this bug for a long time. Feel free to reopen if your have problems with installing modern ROSA Desktop Fresh R5.