Bug 1298 - qutim2 don`t load
: qutim2 don`t load
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-22 03:14 MSK by Phideaux
Modified: 2014-08-28 13:16 MSD (History)
4 users (show)

See Also:
RPM Package: qutim2-0.2.1.git.630-0.1-rosa2012.1
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Phideaux 2012-12-22 03:14:01 MSK
Description of problem:
qutim2 don`t load

Version-Release number of selected component (if applicable):
$ uname -a
Linux rosa.t410 3.6.10-nrj-desktop-1rosa #1 SMP PREEMPT Wed Dec 12 13:59:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
try to load qutim :)

Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-12-23 16:45:55 MSK
I have not found any errors with launching of qutim. What type of error do You get?
Could You open konsole and start qutim from it. After crash of qutim please give me output from konsole.
Comment 2 Denis Silakov 2012-12-25 13:42:50 MSK
Unfortunately, we can't reproduce the issue atm. It would be useful if you launch qutim from console and provide us with its output.
Comment 3 Phideaux 2012-12-27 14:14:27 MSK
sergey-rosa@rosa ~]$ qutim
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Debug: ("/usr/bin/plugins", "/usr/lib64/qutim", "/usr/lib64/qutim/plugins", "/usr/lib64/qutim", "/usr/lib64/qutim/plugins", "/usr/PlugIns", "//plugins") 
Debug: "/usr/lib64/qutim/libhistman.so" 
Debug: "/usr/lib64/qutim/libimagepub.so" 
Debug: "/usr/lib64/qutim/libirc.so" 
Debug: "/usr/lib64/qutim/libjabber.so" 
Debug: "/usr/lib64/qutim/libjuick.so" 
Debug: "/usr/lib64/qutim/libkdecrash.so" 
Debug: "/usr/lib64/qutim/libkdeemoticons.so" 
Debug: "/usr/lib64/qutim/libkdenotification.so" 
Debug: "/usr/lib64/qutim/libkdephonon.so" 
Debug: "/usr/lib64/qutim/libkdespeller.so" 
Debug: "/usr/lib64/qutim/libmassmessaging.so" 
Debug: "/usr/lib64/qutim/libmrim.so" 
Debug: "/usr/lib64/qutim/libmsn.so" 
Debug: "/usr/lib64/qutim/liboscar.so" 
Debug: "/usr/lib64/qutim/libplugman.so" 
Debug: "/usr/lib64/qutim/libtwitter.so" 
Debug: "/usr/lib64/qutim/liburlpreview.so" 
Debug: "/usr/lib64/qutim/libvkontakte.so" 
Debug: "/usr/lib64/qutim/libweather.so" 
Debug: "/usr/lib64/qutim/libyandexnarod.so" 
Debug: Share paths: ("", "../share/qutim", "/home/sergey-rosa/.config/qutim") 
Debug: Simple plugin "History Manager" was loaded
Debug: Simple plugin "ImagePub" was loaded
Debug: Protocol "IRC" was loaded
Debug: Protocol "Jabber" was loaded
Debug: Simple plugin "Juick" was loaded
Ошибка сегментирования (слепок снят)
Comment 4 Denis Silakov 2012-12-27 21:09:41 MSK
Wow... Could you please provide us with core dump file?

You can find the instruction on how to simplify creation of core dumps here:
http://bugs.rosalinux.ru/show_bug.cgi?id=804#c8
Comment 5 Phideaux 2012-12-28 08:08:36 MSK
(In reply to comment #4)
> Wow... Could you please provide us with core dump file?
> 
> You can find the instruction on how to simplify creation of core dumps here:
> http://bugs.rosalinux.ru/show_bug.cgi?id=804#c8

[root@rosa sergey-rosa]# unlimit -f unlimited
bash: unlimit: команда не найдена
[root@rosa sergey-rosa]# ulimit -f unlimited
[root@rosa sergey-rosa]# ulimit -c unlimited
[root@rosa sergey-rosa]# ulimit -c
unlimited
[root@rosa sergey-rosa]# echo "core" > /proc/sys/kernel/core_pattern
[root@rosa sergey-rosa]# cat /proc/sys/kernel/core_pattern
core
[root@rosa sergey-rosa]# dolphin
dolphin(7394)/kdeui (kdelibs): Session bus not found 
To circumvent this problem try the following command (with Linux and bash) 
export $(dbus-launch) 
Аварийный останов (слепок снят)
[root@rosa sergey-rosa]# ls core*
core.7394
Comment 6 Phideaux 2012-12-28 08:23:03 MSK
[root@rosa sergey-rosa]# export $(dbus-launch)
[root@rosa sergey-rosa]# dolphin
"/usr/bin/dolphin(7684)" Soprano: "Could not connect to server at /tmp/ksocket-root/nepomuk-socket (ÐÐµÑ Ñакого Ñайла или каÑалога)"
"/usr/bin/dolphin(7684)" Soprano: "Could not connect to server at /tmp/ksocket-root/nepomuk-socket (ÐÐµÑ Ñакого Ñайла или каÑалога)"
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
kbuildsycoca4 running...
kbuildsycoca4(7696) KConfigGroup::readXdgListEntry: List entry MimeType in "plasma-wallpaper-image.desktop" is not compliant with XDG standard (missing trailing semicolon). 
kbuildsycoca4(7696) KConfigGroup::readXdgListEntry: List entry Actions in "ServiceMenus/audioconvert4.desktop" is not compliant with XDG standard (missing trailing semicolon). 
kbuildsycoca4(7696) KConfigGroup::readXdgListEntry: List entry MimeType in "ServiceMenus/audiofrommovie4.desktop" is not compliant with XDG standard (missing trailing semicolon). 
kbuildsycoca4(7696) KConfigGroup::readXdgListEntry: List entry Actions in "ServiceMenus/audiofrommovie4.desktop" is not compliant with XDG standard (missing trailing semicolon). 
dolphin(7684) KXMLGUI::ActionList::plug: Index  13  is not within range (0 -  9 
Object::connect: No such slot DolphinMainWindow::focusChanged(QWidget*,QWidget*)
Object::connect:  (sender name:   'dolphin')
Object::connect:  (receiver name: 'Dolphin#1')
dolphin(7684) KSambaSharePrivate::testparmParamValue: We got some errors while running testparm "Load smb config files from /etc/samba/smb.conf
Loaded services file OK.
Warning: Service printers defines a print command, but rameter is ignored when using CUPS libraries.
" 
error of bind: Нет такого файла или каталога
Object::connect: No such slot FileSettings::currentShareChanged(QTableWidgetItem*,QTableWidgetItem*)
Object::connect:  (sender name:   'settingsTable')
Object::connect:  (receiver name: 'FileSettings')
construct plugin
Comment 7 Phideaux 2012-12-28 08:27:14 MSK
After 
# export $(dbus-launch)
dolphin has started.
Comment 8 Denis Silakov 2012-12-28 11:42:48 MSK
That's nice, but that was example for dolphin; in order to get a core file for qutim, you should launch qutim, not dolphin. Sorry for confusion.

So in your case the sequence of commands should be like the following:

$ su
# ulimit -f unlimited
# ulimit -c unlimited

# echo "core" > /proc/sys/kernel/core_pattern

# qutim

# ls core*


If there is a file starting with 'core', please attach it to this bug (if there are several files, attach all of them).
Comment 9 Phideaux 2012-12-28 21:10:59 MSK
(In reply to comment #8)
> That's nice, but that was example for dolphin; in order to get a core file
> for qutim, you should launch qutim, not dolphin. Sorry for confusion.
> 
> So in your case the sequence of commands should be like the following:
> 
> $ su
> # ulimit -f unlimited
> # ulimit -c unlimited
> 
> # echo "core" > /proc/sys/kernel/core_pattern
> 
> # qutim
> 
> # ls core*
> 
> 
> If there is a file starting with 'core', please attach it to this bug (if
> there are several files, attach all of them).

The size of core-file is 37816K. Anyway attach it?
Comment 10 Phideaux 2012-12-28 21:21:13 MSK
Sorry. Core-file is left after dolphin crash. Qutim hasn`t load. And there isn`t core-file after that.

 [root@rosa sergey-rosa]# ulimit -f unlimited
[root@rosa sergey-rosa]# ulimit -c unlimited
[root@rosa sergey-rosa]# echo "core" > /proc/sys/kernel/core_pattern
[root@rosa sergey-rosa]# qutim
Debug: ("/usr/bin/plugins", "/usr/lib64/qutim", "/usr/lib64/qutim/plugins", "/usr/lib64/qutim", "/usr/lib64/qutim/plugins", "/usr/PlugIns", "//plugins") 
Debug: "/usr/lib64/qutim/libhistman.so" 
Debug: "/usr/lib64/qutim/libimagepub.so" 
Debug: "/usr/lib64/qutim/libirc.so" 
Debug: "/usr/lib64/qutim/libjabber.so" 
Debug: "/usr/lib64/qutim/libjuick.so" 
Debug: "/usr/lib64/qutim/libkdecrash.so" 
Debug: "/usr/lib64/qutim/libkdeemoticons.so" 
Debug: "/usr/lib64/qutim/libkdenotification.so" 
Debug: "/usr/lib64/qutim/libkdephonon.so" 
Debug: "/usr/lib64/qutim/libkdespeller.so" 
Debug: "/usr/lib64/qutim/libmassmessaging.so" 
Debug: "/usr/lib64/qutim/libmrim.so" 
Debug: "/usr/lib64/qutim/libmsn.so" 
Debug: "/usr/lib64/qutim/liboscar.so" 
Debug: "/usr/lib64/qutim/libplugman.so" 
Debug: "/usr/lib64/qutim/libtwitter.so" 
Debug: "/usr/lib64/qutim/liburlpreview.so" 
Debug: "/usr/lib64/qutim/libvkontakte.so" 
Debug: "/usr/lib64/qutim/libweather.so" 
Debug: "/usr/lib64/qutim/libyandexnarod.so" 
Debug: Share paths: ("", "../share/qutim", "/root/.config/qutim") 
Debug: Simple plugin "History Manager" was loaded
Debug: Simple plugin "ImagePub" was loaded
Debug: Protocol "IRC" was loaded
Debug: Protocol "Jabber" was loaded
Debug: Simple plugin "Juick" was loaded
Ошибка сегментирования (слепок снят)
[root@rosa sergey-rosa]# ls core*                                                                   
ls: невозможно получить доступ к core*: Нет такого файла или каталога
Comment 11 Denis Silakov 2012-12-29 22:42:48 MSK
It's a pity, can't say much without a core. Well, we'll try to reproduce the failure...
Comment 12 Andrey Bondrov 2013-11-11 18:57:00 MSK
Is the bug still valid?
Comment 13 Denis Silakov 2014-08-27 20:36:11 MSD
Well, at least in 2014.1 platform it works fine on my 64bit machine.
Comment 14 FirstLevel 2014-08-28 09:33:24 MSD
(In reply to comment #13)
> Well, at least in 2014.1 platform it works fine on my 64bit machine.

Strange comment because we does not have 2014.1 platform for ussual users.
Comment 15 Denis Silakov 2014-08-28 09:35:49 MSD
(In reply to comment #14)
> (In reply to comment #13)
> > Well, at least in 2014.1 platform it works fine on my 64bit machine.
> 
> Strange comment because we does not have 2014.1 platform for ussual users.

Yes, but most developers are concenrated on 2014.1 now and it is very unlikely that we will fix any bugs in contrib packages in 2012.1.

And users of 2012.1 will be encouraged to update to 2014.1 after the release.
Comment 16 Andrey Bondrov 2014-08-28 13:16:15 MSD
(In reply to comment #13)
> Well, at least in 2014.1 platform it works fine on my 64bit machine.

BTW, works fine for me in 2012.1 i586, I use it every day.