Bug 1292 - With 2 batteries remaining time calculates for one of them or not calculates at all
: With 2 batteries remaining time calculates for one of them or not calculates ...
Status: CONFIRMED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-21 22:31 MSK by Denis Koryavov
Modified: 2014-10-08 14:46 MSD (History)
1 user (show)

See Also:
RPM Package: plasma-applet-battery-4.9.4-3-rosa2012.1.x86_64
ISO-related:
Bad POT generating:
Upstream: known


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Koryavov 2012-12-21 22:31:07 MSK
Description of problem:
I have Lenovo T420s laptop and 2 batteries - main and second installed in the UltraBay port. In ROSA Marathon 2012 everything worked fine - I could see remaining time and percent of charge for any battery, but in ROSA Desktop.Fresh 2012 I see nothing. 

The most annoying fact  of this, that I can't see when the charge of my batteries will become to critical, I see 100% of charge most of the time. But if I close the lid of my laptop and open it again, I see sometimes that the battery is discharged for some percent. 

If I run "acpi: in konsole I can see the charge for each my battery.

I found simular bugs in the KDE bugzilla:
https://bugs.kde.org/show_bug.cgi?id=253453
https://bugs.kde.org/show_bug.cgi?id=301533

In the last bug, I see that this problem is fixed: https://bugs.kde.org/show_bug.cgi?id=301533#c21 

But, it still present in KDE 4.9.4. 

Version-Release number of selected component (if applicable):
plasma-applet-battery-4.9.4-3-rosa2012.1.x86_64

How reproducible:
Always
Comment 1 Denis Koryavov 2012-12-21 22:34:19 MSK
I forgot to say, that in GNOME version everything works fine. Even if it installed in VirtualBox.
Comment 2 Denis Koryavov 2013-01-04 20:00:31 MSK
I solved my problem by installing plasma-applet-battery-4.8.3-4-rosa.lts2012.0.x86_64 from ROSA Marathon 2012. Now I can see my both batteries. As a plus I can see remaining time (and do not see that annoying hint for applet which was introduced for the new version of applet). 

I suggest to build plasma-applet-battery-4.8.X for the ROSA Desktop.Fresh 2012, so¸ users who have several batteries will have a quick workaround. Or maybe it will be better to use this version of applet by default?
Comment 3 FirstLevel 2014-10-08 14:46:32 MSD
Please check the problem for new release
http://mirror.rosalab.ru/rosa/rosa2014.1/iso/ROSA.Fresh.R4/