Bug 129 - Support for QXL X11 driver
: Support for QXL X11 driver
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal enhancement
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-25 21:45 MSD by Nux
Modified: 2012-04-28 10:51 MSD (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nux 2012-04-25 21:45:59 MSD
Description of problem:

Hello,

The Live media graphical screen freezes upon KDE load on virtual systems with KVM QXL virtual cards, this is because the media does not contain a QXL driver.
The package name is: x11-driver-video-qxl.

Merely installing it is not enough, as KDE or X11 will crash once they are loaded with this driver; I believe the solution would be to upgrade it to version 0.0.14 (ROSA current one is 0.0.13).


Also,

Version-Release number of selected component (if applicable):


How reproducible:
Always, at least with build 240

Steps to Reproduce:
1. Build a KVM virtual machine on EL6 with Spice and QXL video
2. Launch the Live ISO build 240, it will crash after KDE welcome screen.
3.
Comment 1 Alexander Burmashev 2012-04-25 21:53:23 MSD
Thanks for the report and proposed solution i will do it.
Please note that we currently have a mass rebuild on our build server so it may take some time.
Comment 2 Nux 2012-04-25 22:22:03 MSD
Sure, I can wait, if you remember to update this bug once it is finished I'll gladly test it.

Thanks!
Comment 4 Nux 2012-04-27 00:20:34 MSD
Thanks a lot, Alex for the new packages. They install fine, now KDE is loading and I even get 400 FPS in glx_gears BUT ... my mouse is invisible which is making everything complicated :-)
Unfortunately I haven't had much time to investigate but will try to do so in the next days.
Comment 5 Alexander Burmashev 2012-04-27 04:58:46 MSD
I published it to the repo, and will look for the possible bug with cursor to fix it.
Comment 6 Nux 2012-04-28 05:09:32 MSD
Alex,

I reinstalled clean from build 248 and did a full update including restricted and non-free repos and everything seems to be working very well now.
I had to disable KDE effects as they're too much for the poor virtual GPU, but other than that it all works beautifully. Thanks a lot for your efforts!

Feel free to change status to RESOLVED.
Comment 7 Alexander Burmashev 2012-04-28 10:51:53 MSD
good to know it