Bug 1286 - [UPDATE REQUEST] gdm
: [UPDATE REQUEST] gdm
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-21 14:40 MSK by Arkady L. Shane
Modified: 2012-12-29 13:30 MSK (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
alexander.petryakov: qa_verified+
dmitry.romashkin: secteam_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arkady L. Shane 2012-12-21 14:40:36 MSK
Advisory:
Fixes problem with login after autologin. Was unavailable to login to the system after logout if autologin was enabled.

You can test it on this image: http://file-store.rosalinux.ru/api/v1/file_stores/e8e2819fe263b7c59ad188d0128f24ba4c06995f

Buildlists:
https://abf.rosalinux.ru/build_lists/857815
https://abf.rosalinux.ru/build_lists/857816
Comment 1 Arkady L. Shane 2012-12-21 14:40:55 MSK
*** Bug 1285 has been marked as a duplicate of this bug. ***
Comment 2 Alexander Petryakov 2012-12-27 00:48:14 MSK
Arkady, I can't reproduce error.
1) Set autologin in file /etc/X11/gdm/custom.conf :
[daemon]
AutomaticLoginEnable=true
AutomaticLogin=username
2) reboot (autologin is successful )
3) logout 
4) invitation insert password 
5) login is successful 
6) logout 
7) reboot
8) autologin is successful 

Can you specify steps for reproduce error?
Comment 3 Arkady L. Shane 2012-12-27 14:11:34 MSK
Maybe this problem shows if user have not password, as live user on livecd.

You can test it in this old image with old gdm (logout and login on LIVE):
https://abf.rosalinux.ru/platforms/144/products/32/product_build_lists/795

This bug in Fedora bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=881896
Comment 4 Alexander Petryakov 2012-12-28 16:42:13 MSK
gdm-3.6.2-2
************** Advisory **************
Fixes problem with login after autologin. Was unavailable to login to the system after logout if autologin was enabled.
**************************************
QA Verified