Bug 1276 - Could not install ROSA 2012.1 Fresh on HP ProBook 6465b
: Could not install ROSA 2012.1 Fresh on HP ProBook 6465b
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-20 13:22 MSK by FirstLevel
Modified: 2013-09-17 03:11 MSD (History)
4 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
blinking screen (1.50 MB, image/jpeg)
2012-12-20 13:22 MSK, FirstLevel
Details
F12 messages (1.68 MB, image/jpeg)
2012-12-20 13:22 MSK, FirstLevel
Details
F12 messages too (1.67 MB, image/jpeg)
2012-12-20 13:23 MSK, FirstLevel
Details
lspci (1.61 MB, image/jpeg)
2012-12-20 13:23 MSK, FirstLevel
Details
lspcidrake (1.82 MB, image/jpeg)
2012-12-20 13:23 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-12-20 13:22:30 MSK
Created attachment 935 [details]
blinking screen

Description of problem:
Could not install ROSA 2012.1 Fresh on HP ProBook 6465b
I have tried live mode, standard installation, basic mode.
I have black screen at the beginning and on the stage graphics mode should be appear i see only blinking screen
I have check md5suum - it is correct. I have installed from DVD.
Some diagnostic information are attached.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-12-20 13:22:54 MSK
Created attachment 936 [details]
F12 messages
Comment 2 FirstLevel 2012-12-20 13:23:09 MSK
Created attachment 937 [details]
F12 messages too
Comment 3 FirstLevel 2012-12-20 13:23:19 MSK
Created attachment 938 [details]
lspci
Comment 4 FirstLevel 2012-12-20 13:23:30 MSK
Created attachment 939 [details]
lspcidrake
Comment 5 FirstLevel 2012-12-20 14:56:38 MSK
I have installed with options
xdriver=vesa nomodeset
But after installation I have no graphics mode too, only blinkink screen.
Comment 6 Alexander Burmashev 2012-12-20 15:00:16 MSK
Hi, can you please try:
1) Edit the default boot option and add nomodeset after the splash=silent
2) Boot and check if graphics started
Comment 7 FirstLevel 2012-12-20 15:06:21 MSK
I could start system with adding to initial grub2 configuration
xdriver=vesa nomodeset
Comment 8 Alexander Burmashev 2012-12-20 15:07:49 MSK
Did you try just nomodeset ?
And what video driver is loaded? you can check it with lspcidrake -v
Comment 9 FirstLevel 2012-12-20 15:18:53 MSK
(In reply to comment #8)
> Did you try just nomodeset ?
> And what video driver is loaded? you can check it with lspcidrake -v

Ok. It works with nomodeset only. The lspcidrake output:
[sergei@freshx32 ~]$ lspcidrake
bcma            : Broadcom Corporation|BCM4313 802.11b/g/n Wireless LAN Controller [NETWORK_OTHER] (rev: 01)
sdhci_pci       : JMicron Technology Corp.|Standard SD Host Controller (rev: 30)
sdhci_pci       : JMicron Technology Corp.|SD/MMC Host Controller [SYSTEM_OTHER] (rev: 30)
firewire_ohci   : JMicron Technology Corp.|IEEE 1394 Host Controller [SERIAL_FIREWIRE] (rev: 30)
r8169           : Realtek Semiconductor Co., Ltd.|RTL8111/8168B PCI Express Gigabit Ethernet controller [NETWORK_ETHERNET] (rev: 06)
unknown         : Advanced Micro Devices [AMD]|Family 12h/14h Processor Function 7 [BRIDGE_HOST]
unknown         : Advanced Micro Devices [AMD]|Family 12h/14h Processor Function 5 [BRIDGE_HOST]
unknown         : Advanced Micro Devices [AMD]|Family 12h/14h Processor Function 6 [BRIDGE_HOST]
unknown         : Advanced Micro Devices [AMD]|Family 12h/14h Processor Function 4 [BRIDGE_HOST]
k10temp         : Advanced Micro Devices [AMD]|Family 12h/14h Processor Function 3 [BRIDGE_HOST]
unknown         : Advanced Micro Devices [AMD]|Family 12h/14h Processor Function 2 [BRIDGE_HOST]
unknown         : Advanced Micro Devices [AMD]|Family 12h/14h Processor Function 1 [BRIDGE_HOST]
unknown         : Advanced Micro Devices [AMD]|Family 12h/14h Processor Function 0 [BRIDGE_HOST] (rev: 43)
ehci_hcd        : Advanced Micro Devices [AMD]|Hudson USB EHCI Controller [SERIAL_USB] (rev: 11)
ohci_hcd        : Advanced Micro Devices [AMD]|Hudson USB OHCI Controller [SERIAL_USB] (rev: 11)
shpchp          : Advanced Micro Devices [AMD]|Hudson PCI to PCI bridge (PCIE port 0) [BRIDGE_PCI]
ohci_hcd        : Advanced Micro Devices [AMD]|Hudson USB OHCI Controller [SERIAL_USB] (rev: 11)
unknown         : Advanced Micro Devices [AMD]|Hudson PCI Bridge [BRIDGE_PCI] (rev: 40)
unknown         : Advanced Micro Devices [AMD]|Hudson LPC Bridge [BRIDGE_ISA] (rev: 11)
snd_hda_intel   : Advanced Micro Devices [AMD]|Hudson Azalia Controller [MULTIMEDIA_AUDIO_DEV] (rev: 01)
i2c_piix4       : Advanced Micro Devices [AMD]|Hudson SMBus Controller [SERIAL_SMBUS] (rev: 13)
ehci_hcd        : Advanced Micro Devices [AMD]|Hudson USB EHCI Controller [SERIAL_USB] (rev: 11)
ohci_hcd        : Advanced Micro Devices [AMD]|Hudson USB OHCI Controller [SERIAL_USB] (rev: 11)
ehci_hcd        : Advanced Micro Devices [AMD]|Hudson USB EHCI Controller [SERIAL_USB] (rev: 11)
ohci_hcd        : Advanced Micro Devices [AMD]|Hudson USB OHCI Controller [SERIAL_USB] (rev: 11)
ahci            : Advanced Micro Devices [AMD]|Hudson SATA Controller [AHCI mode] [STORAGE_SATA] (rev: 40)
shpchp          : Advanced Micro Devices [AMD]|Family 12h Processor Root Port [BRIDGE_PCI]
shpchp          : Advanced Micro Devices [AMD]|Family 12h Processor Root Port [BRIDGE_PCI]
shpchp          : Advanced Micro Devices [AMD]|Family 12h Processor Root Port [BRIDGE_PCI]
snd_hda_intel   : Advanced Micro Devices [AMD] nee ATI|BeaverCreek HDMI Audio [Radeon HD 6500D and 6400G-6600G series] [MULTIMEDIA_AUDIO_DEV]
Card:ATI Radeon HD 6400 and later (ati/fglrx): Advanced Micro Devices [AMD] nee ATI|Device 9648 [DISPLAY_VGA]
unknown         : Advanced Micro Devices [AMD]|Family 12h Processor Root Complex [BRIDGE_HOST]
hub             : Linux 3.6.10-nrj-desktop-1rosa ohci_hcd|OHCI Host Controller [Hub|Unused|Full speed (or root) hub]
hub             : Linux 3.6.10-nrj-desktop-1rosa ohci_hcd|OHCI Host Controller [Hub|Unused|Full speed (or root) hub]
hub             : Linux 3.6.10-nrj-desktop-1rosa ohci_hcd|OHCI Host Controller [Hub|Unused|Full speed (or root) hub]
hub             : Linux 3.6.10-nrj-desktop-1rosa ehci_hcd|EHCI Host Controller [Hub|Unused|Full speed (or root) hub]
hub             : Linux 3.6.10-nrj-desktop-1rosa ehci_hcd|EHCI Host Controller [Hub|Unused|Full speed (or root) hub]
hub             : Linux 3.6.10-nrj-desktop-1rosa ehci_hcd|EHCI Host Controller [Hub|Unused|Full speed (or root) hub]
hub             : Linux 3.6.10-nrj-desktop-1rosa ohci_hcd|OHCI Host Controller [Hub|Unused|Full speed (or root) hub]
btusb           : Broadcom Corp|HP Integrated Module [Wireless|Radio Frequency|Bluetooth]
[sergei@freshx32 ~]$
Comment 10 FirstLevel 2012-12-20 15:28:17 MSK
I set nomodeset as default parameter for grub2.
Is this final solution of my problem?
Comment 11 Alexander Burmashev 2012-12-20 15:29:39 MSK
nomodeset is one of the wide recommended options, if it helps you - it can be named a "fix", but it still remains a workaround.
Comment 12 Aleksandr Kazantcev 2012-12-20 15:32:17 MSK
You may install proprietary driver via XFdrake...
Comment 13 FirstLevel 2012-12-20 15:48:18 MSK
(In reply to comment #12)
> You may install proprietary driver via XFdrake...

Yes it works
I have installed proprietary driver and exclude nomodeset from grub2 options. System starts successfully
Comment 14 Stanislav Fomin 2013-09-17 03:11:28 MSD
>System starts successfully