Bug 1252 - KLook stack folder integtation
: KLook stack folder integtation
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: Sergey Borovkov
: ROSA Linux Bugs
: ROSA 2012.1 Release
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-17 12:22 MSK by Sergey Borovkov
Modified: 2013-01-09 10:25 MSK (History)
6 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
alexander.petryakov: qa_verified+
dmitry.romashkin: secteam_verified+
alex.burmashev: published+


Attachments
klook in embedded mode not correct shows .pcx files (see attachment) (138.78 KB, image/png)
2012-12-18 02:14 MSK, Alexander Petryakov
Details
klook+.pcx (184.21 KB, image/png)
2012-12-18 13:20 MSK, Postnikov Dmitry
Details
.pcx file (803.39 KB, image/x-pcx)
2012-12-18 22:45 MSK, Alexander Petryakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Borovkov 2012-12-17 12:22:28 MSK
Description of problem:
Klook does not exit when losing focus. That causes stackfolder to hang waiting for klook to exit. (this video demonstrates the problem http://cdn.2safe.com/1130769033539/StackFolder+Klook.webm_
Comment 1 Sergey Borovkov 2012-12-17 12:26:21 MSK
Advisory:
This should fix the problem with klook in embedded mode. Also note that this package should fix following bug (http://bugs.rosalinux.ru/show_bug.cgi?id=1174)

Buildlists:
https://abf.rosalinux.ru/build_lists/857004
https://abf.rosalinux.ru/build_lists/857005
Comment 2 Sergey Borovkov 2012-12-17 12:34:40 MSK
Advisory:
This should fix the problem with klook in embedded mode. Also note that this package should fix following bug (http://bugs.rosalinux.ru/show_bug.cgi?id=1174).
I am creating another copy of previous comment because it seems bug's status did not change to RESOLVED FIXED.

Buildlists:
https://abf.rosalinux.ru/build_lists/857004
https://abf.rosalinux.ru/build_lists/857005
Comment 3 Postnikov Dmitry 2012-12-17 13:30:17 MSK
Crash Plasma:
http://cdn.2safe.com/1976161033025/screencast7.mov

plasma-applet-stackfolder-2.4-3-rosa2012.1.x86_64
klook-2.0-7-rosa2012.1.x86_64
Comment 4 Sergey Borovkov 2012-12-17 13:34:37 MSK
Dmitry: could you please create a separate bug for that crash? I will take a look at it now, but still it has nothing to do with this bug (and I'd really like to fix this bug right now, because it can be really annoying)
Comment 5 Sergey Borovkov 2012-12-17 17:23:07 MSK
Dmitry: I took a look at the video - it's stack folder that crashes plasma-desktop, not klook... Klook has nothing to do with plasma-desktop and can't crash plasma (while stack folder is plasmoid).
Comment 6 Postnikov Dmitry 2012-12-17 18:11:49 MSK
I created a new bug 1253 this afternoon.
Comment 7 Alexander Petryakov 2012-12-18 02:14:52 MSK
Created attachment 927 [details]
klook in embedded mode not correct shows .pcx files (see attachment)
Comment 8 Sergey Borovkov 2012-12-18 10:42:36 MSK
Alexander: it would be nice if you would attach pcx file, not screenshot. It's possible that the file you are showing just has low resolution, or it could be bug in Qt's handling of pcx files (giving wrong resolution or whatever). Anyway I can't find out more without that file...
Comment 9 Postnikov Dmitry 2012-12-18 13:20:05 MSK
I have .pcx files at all no-shows klook. In Gwenview i converted .jpg to .pcx file.

klook-2.0-7-rosa2012.1.x86_64

I attached screenshot & .pcx file.
Comment 10 Postnikov Dmitry 2012-12-18 13:20:31 MSK
Created attachment 928 [details]
klook+.pcx
Comment 11 Postnikov Dmitry 2012-12-18 13:22:29 MSK
.pcx file: http://cdn.2safe.com/7564033559/ddd1.pcx
Comment 12 Alexander Petryakov 2012-12-18 22:45:58 MSK
Created attachment 931 [details]
.pcx file
Comment 13 Sergey Borovkov 2012-12-18 23:14:36 MSK
Hi, I tested the file and it looks like it's not klook's problem (it opens in proper size when opening from dolphin) but rather stackfolder's (stackfolder unlike dolphin passes size that klook should use). So can you please create a separate bug for that (for stackfolder)?
Comment 14 Sergey Borovkov 2012-12-20 16:46:46 MSK
Advisory:
Fixed stupid regression in this build list (that caused crash on exit sometimes. It was noticeable only when running klook from terminal). Also it would be nice to have some feedback please. I answered all questions about all found bugs..

https://abf.rosalinux.ru/build_lists/857642
https://abf.rosalinux.ru/build_lists/857643
Comment 15 Alexander Petryakov 2012-12-21 00:52:16 MSK
klook-2.0-9
************** Advisory **************
This should fix the problem with klook in embedded mode. Also note that this package should fix following bug (http://bugs.rosalinux.ru/show_bug.cgi?id=1174, but pcx files have incorrect size (http://bugs.rosalinux.ru/show_bug.cgi?id=1284))
Fixed regression in this build list (that caused crash on exit sometimes. It was noticeable only when running klook from terminal)
**************************************