Bug 1246 - Unable to install ROSA 2012.1 RC on DELL D610
: Unable to install ROSA 2012.1 RC on DELL D610
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: i586 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-15 14:21 MSK by fvill
Modified: 2013-11-08 23:48 MSK (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
isolinux.cfg from a written flash drive (2.16 KB, text/plain)
2012-12-15 17:10 MSK, fvill
Details
X crash log (1.90 MB, image/jpeg)
2012-12-15 20:50 MSK, fvill
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fvill 2012-12-15 14:21:32 MSK
Description of problem:
On a old D610, ROSA 2012.1 RC 586 cannot be install. Boot menu appears correctly, you can select Install entry, then you have the dracut screenloader.... And this is it. End of story. Nothing happens after... except a black screen.


Version-Release number of selected component (if applicable):
ROSA 2012.1 RC 586


How reproducible:
All the time...

Steps to Reproduce:
1. burn the iso
2. boot the iso
3. tada
Comment 1 fvill 2012-12-15 14:23:43 MSK
lspci output

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 01)
03:01.0 CardBus bridge: Texas Instruments PCI6515 Cardbus Controller
03:01.5 Communication controller: Texas Instruments PCI6515 SmartCard Controller
03:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
Comment 2 Alexander Burmashev 2012-12-15 15:14:33 MSK
If you have any working linux system can you please insert flash drive there and check how it is detected bt  blkid ?
Or check volume info in Windows, what is written there ?
Comment 3 fvill 2012-12-15 16:20:05 MSK
Here is the output of the blkid command

[root@localhost ~]# blkid 
/dev/sda1: SEC_TYPE="msdos" LABEL="DellUtility" UUID="07D6-0111" TYPE="vfat" 
/dev/sda5: UUID="8310a1fe-7f40-4b79-ba8e-d4da5878d240" TYPE="ext4" 
/dev/sda6: UUID="51aac237-7be2-4c96-900c-c77a76e8bf4f" TYPE="swap" 
/dev/sda7: UUID="c507b447-2cdf-47a4-94e6-7e0ac1046fcd" TYPE="ext4" 
/dev/sdb1: LABEL="TETARD" UUID="5FB520AF276B4E9A" TYPE="ntfs" 



Current OS is linux Mandriva 2011
Comment 4 fvill 2012-12-15 16:24:13 MSK
sdb is the flash drive.
sda is the local drive
Comment 5 Alexander Burmashev 2012-12-15 16:50:35 MSK
Ok, thanks. Can you now mount  the flash drive and attach isolinux/isolinux.cfg here ? Or copy paste it here.

Please note - mount and copy from writtent flash drive, not from iso image.
Comment 6 fvill 2012-12-15 17:10:37 MSK
Created attachment 921 [details]
isolinux.cfg from a written flash drive

Here is the asked file.

Just to be sure I clear myself about this bug. Here is the scenario :

The installation correctly boot, I have the grub menu. I can select an entry in the boot menu. The dracut screenloader goes on. Once the dracut has finished, my screen is black. All I can do is to turn off the computer by hiting the powerbutton.
Comment 7 Alexander Burmashev 2012-12-15 17:27:02 MSK
Ok, can you try boot again from that flash-drive and cnange, press tab any option and and change root=live:CDLABEL=ROSA.2012.Desktop.RC.i586 to root=UUID=5FB520AF276B4E9A and then try booting ?
Comment 8 fvill 2012-12-15 20:50:38 MSK
Created attachment 922 [details]
X crash log

when I set root=UUID=5FB520AF276B4E9A, I get dracut error saying root can not be found /dev/disk/by_uuid/5FB520AF276B4E9A not found.

I modify to use this uuid=2012-12-07-07-42-58-00

dracut is happy. but.... black screen.... nothing changes.


But after digging a little bit on google, I found I should try to boot with nomodeset param, which I did. .... black screen but alt-f2 works. I get prompt.
In fact, X crash at startup with explain the black screen.

I attach the picture of the log.
Comment 9 fvill 2013-01-13 19:45:48 MSK
I found a workaround.
Disable the touchpad in bios and use a external mouse.
You can enable the touchpad once the system is install.

This should be mentionned in errata.
Comment 10 Denis Silakov 2013-01-14 15:36:21 MSK
Thanks, added to errata.

Leaving the bug open since the issue itself is not actually resolved.