Bug 1245 - wine 32 bit wine cfg
: wine 32 bit wine cfg
Status: RESOLVED DUPLICATE of bug 2457
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Contributed Packages
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-15 01:19 MSK by Jovan
Modified: 2013-08-08 14:20 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jovan 2012-12-15 01:19:04 MSK
Hello,

i try wine version 1.5.13 32 bit. It is not possible to run winecfg (wine configurator) 

[jovan@localhost ~]$ winecfg
/usr/bin/winecfg: Line 33: /usr/bin/wine64: not found
[jovan@localhost ~]$ 

so it's 32 bit why it search for 64 bit i don't understand that. However it's not possible tu run.
Comment 1 Alexander Khryukin 2012-12-17 15:59:35 MSK
hi.
Please show output of 
uname -a
Comment 2 Alexander Khryukin 2012-12-17 16:49:29 MSK
I get the same result but i'm using just 32bit chroot on 64bit machine.
I rly need your uname -m
Comment 3 Denis Silakov 2012-12-20 13:46:41 MSK
Yes, selection in winecfg currently depends on 'uname -m'. Even if you install 32 bit wine in 64bit environment, winecfg will try to launch wine64.
Comment 4 Jovan 2012-12-21 19:40:37 MSK
So it whould be nice to fix it i cannot start and use programs because of this error.
Comment 5 Alexander Khryukin 2012-12-24 16:08:56 MSK
Simple solution is 

sudo sed -i 's!/usr/bin/wine64!/usr/bin/wine!g'  /usr/bin/winecfg
Comment 6 Aleksandr Kazantcev 2013-08-08 14:20:48 MSD

*** This bug has been marked as a duplicate of bug 2457 ***