Bug 1228 - Network manager crashed while system is starting
: Network manager crashed while system is starting
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-10 21:24 MSK by FirstLevel
Modified: 2014-06-03 16:15 MSD (History)
3 users (show)

See Also:
RPM Package: networkmanager-0.9.2.0-4-rosa.lts2012.0.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments
Diagnostic information (3.19 KB, text/plain)
2012-12-10 21:24 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-12-10 21:24:36 MSK
Created attachment 916 [details]
Diagnostic information

Description of problem:
Network manager crashed while system is starting. In /var/log/messages I have such strings:

Dec  9 16:29:05 localhost networkmanager[3361]: Setting network parameters...
Dec  9 16:29:05 localhost networkmanager[3361]: Starting NetworkManager daemon: [  OK  ]
Dec  9 16:29:05 localhost NetworkManager[3379]: <info> NetworkManager (version 0.9.2.0) is starting...
Dec  9 16:29:05 localhost NetworkManager[3379]: <info> Read config file /etc/NetworkManager/NetworkManager.conf
Dec  9 16:29:05 localhost NetworkManager[3379]: <info> Loaded plugin ifcfg-mdv: (c) 2009 - 2010 Eugeni Dodonov <eugeni@mandriva.com>.
Dec  9 16:29:05 localhost NetworkManager[3379]: <info> Loaded plugin keyfile: (c) 2007 - 2010 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
Dec  9 16:29:05 localhost NetworkManager[3379]:    ifcfg-mdv: parsing /etc/sysconfig/network-scripts/ifcfg-wlan0 ...
Dec  9 16:29:05 localhost NetworkManager[3379]: read_mac_address: assertion `*error == NULL' failed
Dec  9 16:29:05 localhost NetworkManager[3379]: nm_connection_verify: assertion `*error == NULL' failed
Dec  9 16:29:05 localhost NetworkManager[3379]:    ifcfg-mdv:     error: Unable to discover MAC address: ioctl error
Dec  9 16:29:05 localhost NetworkManager[3379]:    ifcfg-mdv: parsing /etc/sysconfig/network-scripts/ifcfg-lo ...
Dec  9 16:29:05 localhost NetworkManager[3379]:    ifcfg-mdv: parsing /etc/sysconfig/network-scripts/ifcfg-eth0 ...
Dec  9 16:29:05 localhost NetworkManager[3379]:    ifcfg-mdv:     read connection 'System eth0'
Dec  9 16:29:05 localhost NetworkManager[3379]:    ifcfg-mdv: parsing /etc/sysconfig/network-scripts/ifcfg-eth1 ...
Dec  9 16:29:05 localhost NetworkManager[3379]:    ifcfg-mdv:     read connection 'System eth1'
Dec  9 16:29:05 localhost NetworkManager[3379]: <info> modem-manager is now available
Dec  9 16:29:05 localhost NetworkManager[3379]: <info> monitoring kernel firmware directory '/lib/firmware'.
Dec  9 16:29:05 localhost NetworkManager[3379]: <error> [1355048945.128462] [nm-dbus-manager.c:338] nm_dbus_manager_start_service(): Could not acquire the NetworkManager service as it is already taken.
Dec  9 16:29:05 localhost NetworkManager[3379]: <error> [1355048945.128481] [main.c:669] main(): failed to start the dbus service.
Dec  9 16:29:05 localhost NetworkManager[3379]: <info> exiting (error)

It looks like periodic disconnection of network interface but I have not found information about disconnection in log file.

I have attached some diagnostic information.

Is is normal?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Postnikov Dmitry 2012-12-10 21:37:06 MSK
(In reply to comment #0)
> Created attachment 916 [details]
> Diagnostic information
> 
> Description of problem:
> Network manager crashed while system is starting. In /var/log/messages I
> have such strings:
> 

> Dec  9 16:29:05 localhost NetworkManager[3379]:    ifcfg-mdv:     error:
> Unable to discover MAC address: ioctl error

You have NW is not able to read the MAC-address of the network card. Do you have a network card is not dead?
Comment 2 Postnikov Dmitry 2012-12-10 21:41:07 MSK
(In reply to comment #1)
> (In reply to comment #0)
> > Created attachment 916 [details]
> > Diagnostic information
> > 
> > Description of problem:
> > Network manager crashed while system is starting. In /var/log/messages I
> > have such strings:
> > 
> 
> > Dec  9 16:29:05 localhost NetworkManager[3379]:    ifcfg-mdv:     error:
> > Unable to discover MAC address: ioctl error
> 
> You have NW is not able to read the MAC-address of the network card. Do you
> have a network card is not dead?

If NW periodically off, so something with the network card. If you have the "external", it is possible contacts bad or moved away. Pull the card out of the slot and insert it again.
Comment 3 FirstLevel 2012-12-11 09:18:34 MSK
(In reply to comment #1)
> (In reply to comment #0)
> > Created attachment 916 [details]
> > Diagnostic information
> > 
> > Description of problem:
> > Network manager crashed while system is starting. In /var/log/messages I
> > have such strings:
> > 
> 
> > Dec  9 16:29:05 localhost NetworkManager[3379]:    ifcfg-mdv:     error:
> > Unable to discover MAC address: ioctl error
> 
> You have NW is not able to read the MAC-address of the network card. Do you
> have a network card is not dead?

Dmitry, did You see attachment?  Strange questions...
Comment 4 Aleksandr Kazantcev 2014-01-27 11:49:25 MSK
Close as no longer answer
Comment 5 FirstLevel 2014-01-27 15:39:34 MSK
Please could You specify true reason for close this ticket?
Comment 6 FirstLevel 2014-06-03 16:11:15 MSD
checking the relevance