Bug 1172 - no translation, incorrect category for kcm_harddrake
: no translation, incorrect category for kcm_harddrake
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-07 22:23 MSK by VictorR2007
Modified: 2012-12-25 12:54 MSK (History)
4 users (show)

See Also:
RPM Package: kcm_harddrake, kcm_drakdvb
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description VictorR2007 2012-12-07 22:23:27 MSK
Description of problem:
No Russian translation.
For kcm_harddrake must X-KDE-System-Settings-Parent-Category=system-administratio
Comment 1 Denis Koryavov 2012-12-07 22:25:52 MSK
I suppose 3 bugs should be enough. :)
Comment 2 Denis Koryavov 2012-12-07 22:26:29 MSK
*** Bug 1170 has been marked as a duplicate of this bug. ***
Comment 3 Denis Koryavov 2012-12-07 22:27:04 MSK
*** Bug 1171 has been marked as a duplicate of this bug. ***
Comment 4 Denis Silakov 2012-12-17 10:43:08 MSK
X-KDE-System-Settings-Parent-Category is set to 'hardware' intentionally - harddrake and printer configuration tools really concern hardware setup, not general system administration. Also note that 'native' KDE tools for printer setup (system-config-printer-kde and kde-print-manager) also belong to 'hardware', not to 'ssytem administration'.

In general, our intention was not to move all items from ROSA Control Center to System Administration Tab in KDE CC (there are already too many elements there), but put ROSA CC items into appropriate tabs in KDE CC. It would be nice to even reproduce the structure of ROSA/MDV CC inside KDE CC, but this turned out to be not easy, so this is a task for future...

As for translations - we'll update them soon.
Comment 5 Denis Silakov 2012-12-20 10:09:32 MSK
Advisory:

Added Russian localization to kcm-harddrake and kcm-drakdvb packages, fixed description of kcm-drakdvb

Build lists:
https://abf.rosalinux.ru/build_lists/857615
https://abf.rosalinux.ru/build_lists/857616
https://abf.rosalinux.ru/build_lists/857613
https://abf.rosalinux.ru/build_lists/857614
Comment 6 Denis Silakov 2012-12-21 10:41:07 MSK
It turned out that something has gone in wrong way in ABF with these packages, I'll rebuild them...
Comment 7 Denis Silakov 2012-12-21 11:08:50 MSK
Advisory:

Added Russian localization to kcm-harddrake and kcm-drakdvb packages, fixed description of kcm-drakdvb

Build lists:
https://abf.rosalinux.ru/build_lists/857774
https://abf.rosalinux.ru/build_lists/857775
https://abf.rosalinux.ru/build_lists/857776
https://abf.rosalinux.ru/build_lists/857777
Comment 8 Vladimir Potapov 2012-12-22 17:20:13 MSK
kcm_printer_manager?
Comment 9 Denis Silakov 2012-12-22 19:49:28 MSK
kcm_printer_manager in its current state is not recommended for users, it seems to be a mistake that it still presents in iso...

Another thing is that this is a standalone application, not a wrapper for drakxtools, and it's localization is not a 5-minute task.

So there will be no fix for this package at the moment.
Comment 10 Vladimir Potapov 2012-12-24 03:42:46 MSK
kcm-drakdvb-1.0-4-rosa2012.1
kcm-harddrake-1.0-6-rosa2012.1
************************ Advisory ********************
Added Russian localization to kcm-harddrake and kcm-drakdvb packages, fixed description of kcm-drakdvb
*******************************************************
Comment 11 Alexander Burmashev 2012-12-25 12:12:19 MSK
published, but can't change the status due to bugzilla error.
Comment 12 Alexander Burmashev 2012-12-25 12:12:28 MSK
published, but can't change the status due to bugzilla error.