Bug 1169 - Please compile Clementine with support for Spotify!
: Please compile Clementine with support for Spotify!
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Package Requests
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-07 17:02 MSK by Martin Sjöstrand
Modified: 2012-12-12 09:57 MSK (History)
1 user (show)

See Also:
RPM Package: Clementine
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Sjöstrand 2012-12-07 17:02:31 MSK
Description of problem:
Spotify does not work under Clementine since it lacks support for the same.

Version-Release number of selected component (if applicable):
1.1

How reproducible:
Every time I open Clementine.

Steps to Reproduce:
1.
2.
3.


The answer from the devs of Clementine: Your distribution has compiled Clementine without the ability to download the Spotify plugin.  You'll need to ask the Rosa Linux developers to make the Clementine package depend on protobuf and qca2, and then the Spotify plugin downloader will be included.

So, please, compile it with support for Spotify.
Comment 1 Denis Silakov 2012-12-10 10:58:24 MSK
Hm, it seems that libspotify is not free software, so we can't just build it for the main repo.

Instead, we can build libspotify for non-free repo and prepare a separate version of clementine for that repo with spotify support.
Comment 2 Denis Silakov 2012-12-11 17:47:44 MSK
Ok, libspotify is now present in the non-free repository.

I have also built experimental clementine with spotify support. Unfortunately, I have no easy way to test it since Sporitfy is not available in Russia.

May I ask you to test the package? It can be downloaded here:

32bit version: http://abf.rosalinux.ru/downloads/dsilakov_personal/repository/rosa2012.1/i586/main/release/clementine-1.1.1-2plf-rosa2012.1.i586.rpm

64bit one: http://abf.rosalinux.ru/downloads/dsilakov_personal/repository/rosa2012.1/x86_64/main/release/clementine-1.1.1-2plf-rosa2012.1.x86_64.rpm

(before testing it, you should install libspotify from non-free repo).
Comment 3 Martin Sjöstrand 2012-12-11 22:10:08 MSK
Thank you, Clementine works just perfectly with Spotify now!
Comment 4 Martin Sjöstrand 2012-12-11 22:11:28 MSK
Sorry, forgot to mention that I installed libspotify and the Clementine-package:)
Comment 5 Denis Silakov 2012-12-12 09:57:57 MSK
Thanks! Clementine with Spotify support has been built for non-free repo, should be available on mirrors during the day. 

So if you want to use clementine with Spotify, just enable the non-free repository.