Bug 1166 - Could I Use vgaswircheroo for my laptop
: Could I Use vgaswircheroo for my laptop
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-07 15:32 MSK by FirstLevel
Modified: 2014-06-03 22:29 MSD (History)
2 users (show)

See Also:
RPM Package: kernel-nrj-desktop-3.0.38-1rosa.lts-1-1
ISO-related:
Bad POT generating:
Upstream:


Attachments
diagnostic information (6.03 KB, text/plain)
2012-12-07 15:32 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-12-07 15:32:10 MSK
Created attachment 856 [details]
diagnostic information

Description of problem:
I have laptop  Samsung 355V5X-S01 with two AMD videocards. Could I use vgaswitcheroo for switching between them?
I have not found /sys/kernel/debug/vgaswitcheroo/switch in my system.
I have attached some diagnostic information.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Denis Silakov 2012-12-07 15:40:21 MSK
It seems that fglrx driver is used? To check, show output of "/sbin/lsmod | grep fglrx".

If so, then it's impossible to use vgaswircheroo, this feature works only with the free radeon driver (x11-driver-video-radeonhd).
Comment 2 Denis Silakov 2012-12-07 15:45:24 MSK
If fglrx is used, I would suggest to try Catalyst Control Center ("amdcccle" command, provided by fglrx-control-center package). Iirc, it provides its own means of switching between cards.
Comment 3 FirstLevel 2012-12-08 15:57:45 MSK
(In reply to comment #1)
> It seems that fglrx driver is used? To check, show output of "/sbin/lsmod |
> grep fglrx".
> 
> If so, then it's impossible to use vgaswircheroo, this feature works only
> with the free radeon driver (x11-driver-video-radeonhd).


The output for 
/sbin/lsmod | grep fglrx 
is nothing.
Comment 4 FirstLevel 2012-12-10 09:41:17 MSK
Also user has told that he has not /etc/X11/xorg.conf at all.
Id he tried to customize X with XFdrake he has got black screen and may be corrected by removing xorg.conf
Comment 5 Denis Silakov 2012-12-10 09:48:41 MSK
Absence of xorg.conf is intentional, for the last couple of years X11 recommend not to use it and to rely of autoconfiguration. Failure with XFdrake can be caused by some wrong configuration wrote in xorg.conf.

As for the initial problem - is 'nomodeset' set among kernel parameters? If yes, it should be dropped.

And maybe it makes sense for the user to install fglrx and try fglrx-control-center?
Comment 6 FirstLevel 2012-12-10 13:24:44 MSK
(In reply to comment #5)
> Absence of xorg.conf is intentional, for the last couple of years X11
> recommend not to use it and to rely of autoconfiguration. Failure with
> XFdrake can be caused by some wrong configuration wrote in xorg.conf.
> 
> As for the initial problem - is 'nomodeset' set among kernel parameters? If
> yes, it should be dropped.
> 
> And maybe it makes sense for the user to install fglrx and try
> fglrx-control-center?

About kernel parameters
[root@localhost serge]# cat /proc/cmdline
BOOT_IMAGE=3.0.38-nrj-desktop-1rosa.lts root=UUID=add4d2b2-22c3-4db5-83bf-a3e7957f1251 logo.nologo quiet resume=UUID=ebca06ad-f316-4761-988a-c522a15225fb splash=silent vga=788
Comment 7 FirstLevel 2014-06-03 16:14:41 MSD
checking the relevance
Comment 8 FirstLevel 2014-06-03 22:29:46 MSD
Case is not actual