Bug 1157 - MPlayer 1.1 for DVD-menu in ROMP
: MPlayer 1.1 for DVD-menu in ROMP
Status: RESOLVED FIXED
Product: Desktop Features
Classification: ROSA Desktop
Component: All
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: Arkady L. Shane
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-06 13:00 MSK by Vladimir Potapov
Modified: 2015-04-02 23:02 MSD (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2012-12-06 13:00:16 MSK
Want to update in the Marathon version of mplayer to 1.1 for support dvd-menu in ROMP.
Comment 1 Denis Silakov 2012-12-17 12:10:14 MSK
Any opinion on this?
Comment 2 Denis Koryavov 2012-12-17 12:19:22 MSK
MPlayer 1.1 requires a new ffmpeg, and I doubt that it will be not dangerous for stable repository.
Comment 3 Vladimir Potapov 2012-12-17 12:29:42 MSK
mplayer 1.1 is release. It updated to 1.1 in all main distros. 
I think we will not have big problems

P.S. Bug status: unconfirmed?
Comment 4 Vladimir Potapov 2012-12-18 11:59:02 MSK
for check the DVD-menu:
1) Insert DVD
2) rosa-media-player dvdnav:////dev/sr0 -mouse-movements

The mplayer 1.0 have artifacts.
Comment 5 Denis Koryavov 2012-12-18 13:04:36 MSK
urpmq --whatrequires mplayer
2mandvd
audiokonverter
audiokonverter
auteur
cmmusic
devede
dpgconv
freevo
gnome-mplayer
hinedo
kplayer
lives
lxdvdrip
mandvd
manslide
mencoder
mozplugger
mplayer
mplayer-gui
mythtv-frontend
ps3mediaserver
qeven
rosa-media-player
rosa-media-player-plugin
smplayer
smplayer-qt4
soundkonverter
subtitleeditor
tovid
tvok
vdr-plugin-mplayer                                                                                                                                                   
vdr-plugin-vdrrip                                                                                                                                                    
vdrrip                                                                                                                                                               
xt7-player3                                                                                                                                                          
xvidcap

urpmq --whatrequires mencoder
2mandvd
acidrip
auteur
devede
dpgconv
file2divx3pass
freevo
h264enc
lives
luciole
magicrescue
mandvd
manslide
ogmrip
ps3mediaserver
qeven
recorditnow
rosa-media-player
tovid
tvok
vdr-plugin-vdrrip
vdrrip
xvidcap

urpmq --whatrequires ffmpeg
2mandvd
dvd-slideshow
feff
ffdiaporama
ffmpeg
gcue2tracks
imagination
kdenlive
kino
kmediafactory
konvertible
luciole
mandvd
miro
mythtv-plugin-archive
ps3mediaserver
pymecavideo
recorditnow
rosa-media-player
sinthgunt
soundkonverter
synfig
tovid
winff
xvidcap

If we update Mplayer and, we should check all these packages. Are you ready to do this?
Comment 6 Vladimir Potapov 2012-12-18 13:33:26 MSK
1) This is packages not critical for system stability
2) This packages work with new mplayer in Mageia
3) LTS is platform for EDU.
4) MPlayer 1.1 officially support blu-ray.
Comment 7 Postnikov Dmitry 2012-12-18 13:37:44 MSK
(In reply to comment #5)
> urpmq --whatrequires mplayer
> ......
> 
> urpmq --whatrequires mencoder
> ..........
> 
> urpmq --whatrequires ffmpeg
> 2mandvd
> ........ 
> If we update Mplayer and, we should check all these packages. Are you ready
> to do this?


When ROSA 2012 Fresh will come out, and why not check out all of these programs?
All we can tested.
Divide between testers and will be tested.
Comment 8 Denis Koryavov 2012-12-18 13:42:37 MSK
OK. :) Arkady, please update mplayer and ffmpeg packages.
Comment 9 Postnikov Dmitry 2012-12-18 13:43:15 MSK
By the way, some of programs listed and now do NOT work. So the list can be reduced. :)
Comment 10 Denis Koryavov 2012-12-18 13:55:53 MSK
Wow... Please, provide this list, then we will know that we did not broke these programs after update.
Comment 11 Postnikov Dmitry 2012-12-18 14:17:59 MSK
(In reply to comment #10)
> Wow... Please, provide this list, then we will know that we did not broke
> these programs after update.


I'm on the last ISO image put a lot of these programs. Some of them did not work. Now I have another ISO image for testing. The memory can remember only:
freevo, mythtv, qeven, xvidcap.


Well... I will now try to поставть all of them and try basic functions. Will add the list. And after updates mplayer re-check. 
The list is large, but the programs are repeated, the result is not very much programmes.
Comment 12 Postnikov Dmitry 2012-12-18 14:41:08 MSK
Started now installation of programs from the list. Some do not even install. :) Do creat new bugs or not? I don't know... :)
Comment 13 Denis Silakov 2012-12-18 14:47:18 MSK
(In reply to comment #12)
> Started now installation of programs from the list. Some do not even
> install. :) Do creat new bugs or not? I don't know... :)

Could you list such non-installable packages here?
Comment 14 Postnikov Dmitry 2012-12-18 14:57:21 MSK
(In reply to comment #13)
> (In reply to comment #12)
> > Started now installation of programs from the list. Some do not even
> > install. :) Do creat new bugs or not? I don't know... :)
> 
> Could you list such non-installable packages here?


I began to creat bugs start to errors in installing programs from the list. So probably it will be easier. Not get lost...
Comment 15 Denis Silakov 2012-12-18 15:16:59 MSK
(In reply to comment #14)
> 
> I began to creat bugs start to errors in installing programs from the list.
> So probably it will be easier. Not get lost...

They won't be lost in any case, we have trackers for such packages:
http://fba.rosalinux.ru/repoclosure/rosa2012.1/main/i586/
http://fba.rosalinux.ru/repoclosure/rosa2012.1/contrib/i586/

We know about these issues and try to fix them.

I don't think it makes sense to file separate bugs for every package from that lists...
Comment 16 Postnikov Dmitry 2012-12-18 15:30:00 MSK
(In reply to comment #15)
> (In reply to comment #14)
> > 
> > I began to creat bugs start to errors in installing programs from the list.
> > So probably it will be easier. Not get lost...
> 
> They won't be lost in any case, we have trackers for such packages:
> http://fba.rosalinux.ru/repoclosure/rosa2012.1/main/i586/
> http://fba.rosalinux.ru/repoclosure/rosa2012.1/contrib/i586/
> 
> We know about these issues and try to fix them.
> 
> I don't think it makes sense to file separate bugs for every package from
> that lists...

Well, all right. I then easier. :)
Comment 17 Postnikov Dmitry 2012-12-18 16:04:13 MSK
I thought that all the better to make mistakes installation programs.
The list of Dmitry put in order. In the end went out a list of programs that need to look at. I have almost all of them installed. Those who are not established - got the bug.
-----------------
Need tested:
2mandvd
auteur
audiokonverter
acidrip
dvd-slideshow
devede
cmmusic
dpgconv
feff
ffdiaporama
ffmpeg
file2divx3pass
freevo
gcue2tracks
gnome-mplayer
h264enc
hinedo
imagination
kdenlive
kino
kplayer
kmediafactory
konvertible
lives
luciole
lxdvdrip
mencoder
mozplugger
mplayer
mplayer-gui
mythtv-frontend
magicrescue
manslide
mandvd
miro
mythtv-plugin-archive
ogmrip
ps3mediaserver
pymecavideo
qeven
rosa-media-player
rosa-media-player-plugin
recorditnow
sinthgunt
soundkonverter
synfig
smplayer
smplayer-qt4
subtitleeditor
tovid
tvok
winff
xvidcap
----------------

I will watch their basic functionality. And after updates mplayer will see.
Comment 18 Postnikov Dmitry 2012-12-18 20:26:44 MSK
I checked some of programs that can be run from SimpleWelcome. The other programs are not in SW. I will continue to deal with them... Later I will write as well about this.
==========================================================
Legend:
---work---    - Program work OK
==not start== - Program not run. Show jumping cursor to the icon and all.
==not work==  - Program run, but not working.
**not tested** - I don't tested. No hardware.

==========================================================
Need tested:

==============not start=====2mandvd
==========not installed=====auteur
audiokonverter
------- work ---------------acidrip
dvd-slideshow
------- work ---------------devede
cmmusic
dpgconv
==============not work======feff
==============not start=====ffdiaporama
------- work ---------------ffmpeg
==============not work======file2divx3pass
====no simbols(no work)=====freevo
------- work ---------------gcue2tracks
------- work ---------------gnome-mplayer
h264enc
==============not start=====hinedo
------- work ---------------imagination
------- work ---------------kdenlive
------- work ---------------kino
------- work ---------------kplayer
------- work ---------------kmediafactory
------- work ---------------konvertible
------- work ---------------lives
==============not start=====luciole
lxdvdrip
------- work ---------------mencoder
mozplugger
------- work ---------------mplayer
------- work ---------------mplayer-gui
********* not tested********mythtv-frontend
magicrescue
------- work ---------------manslide
------- work ---------------mandvd
------- work ---------------miro
********* not tested********mythtv-plugin-archive
==============not work======ogmrip
------- work ---------------ps3mediaserver
pymecavideo
==============not work======qeven
------- work ---------------rosa-media-player
------- work ---------------rosa-media-player-plugin
------- work ---------------recorditnow
==============not work======sinthgunt
------- work ---------------soundkonverter
synfig
------- work ---------------smplayer
smplayer-qt4
subtitleeditor
==============not start=====tovid
==============not start=====tvok
------- work ---------------winff
------- work ---------------xvidcap
=========================================================
Comment 19 Postnikov Dmitry 2012-12-19 02:00:20 MSK
All checked. This is the final list of programs (works/does not work).

After update to mplayer-1.1 need tested all this program?

==============================================
Need tested:
==============not start=====2mandvd
==========not installed=====auteur
------- work ---------------audiokonverter
------- work ---------------acidrip
------- work ---------------dvd-slideshow
------- work ---------------devede
==============not work======cmmusic
------- work ---------------dpgconv
==============not work======feff
==============not start=====ffdiaporama
------- work ---------------ffmpeg
==============not work======file2divx3pass
====no simbols(no work)=====freevo
------- work ---------------gcue2tracks
------- work ---------------gnome-mplayer
------- work ---------------h264enc
==============not start=====hinedo
------- work ---------------imagination
------- work ---------------kdenlive
------- work ---------------kino
------- work ---------------kplayer
------- work ---------------kmediafactory
------- work ---------------konvertible
------- work ---------------lives
==============not start=====luciole
------- work ---------------lxdvdrip
------- work ---------------mencoder
------- work ---------------mozplugger
------- work ---------------mplayer
------- work ---------------mplayer-gui
********* not tested********mythtv-frontend
==========not installed=====magicrescue
------- work ---------------manslide
------- work ---------------mandvd
------- work ---------------miro
********* not tested********mythtv-plugin-archive
==============not work======ogmrip
------- work ---------------ps3mediaserver
==============not start=====pymecavideo
==============not work======qeven
------- work ---------------rosa-media-player
------- work ---------------rosa-media-player-plugin
------- work ---------------recorditnow
==============not work======sinthgunt
------- work ---------------soundkonverter
==============not work======synfig (Only CLI)
------- work ---------------smplayer
==========not installed=====smplayer-qt4
------- work ---------------subtitleeditor
==============not start=====tovid
==============not start=====tvok
------- work ---------------winff
------- work ---------------xvidcap
=====================================================
Comment 20 Arkady L. Shane 2012-12-19 18:27:18 MSK
OK. Many offtopic posts.

Please try these builds:
32-bit: https://abf.rosalinux.ru/build_lists/857500
64-bit: https://abf.rosalinux.ru/build_lists/857501

This is mplayer, built in restricted environment.
Comment 21 Denis Koryavov 2012-12-20 21:55:34 MSK
BTW, the problem is not only in MPlayer. DVD menu disabled in ROMP because MPlayer works not very good with it. So, it will be necessary to update ROMP for use DVD-menu. 

With the new version of mplayer everything works well, but I do not hear any  sound when I try to run a mp4 file. Arkady, please fix this.
Comment 22 Vladimir Potapov 2012-12-21 13:17:48 MSK
(In reply to comment #21)
> BTW, the problem is not only in MPlayer. DVD menu disabled in ROMP because
> MPlayer works not very good with it. So, it will be necessary to update ROMP
> for use DVD-menu. 
> 
> With the new version of mplayer everything works well, but I do not hear any
> sound when I try to run a mp4 file. Arkady, please fix this.
DVD enabled:

rosa-media-player dvdnav:////dev/sr0 -mouse-movements

but movie can't start play

With old mplayer this mode work correctly, only present artifacts.
Comment 23 Denis Koryavov 2012-12-26 14:58:49 MSK
Please, try this: change the parameter use_dvdnav from "false" to  "true" in the settings ( ~/.config/rosamp/rosamp.ini) and try to use DVD-menu directly from the ROMP menu.
Comment 24 Arkady L. Shane 2012-12-26 15:11:05 MSK
Another build with plf enabled options. Please test:

https://abf.rosalinux.ru/build_lists/858149
https://abf.rosalinux.ru/build_lists/870319
Comment 25 Vladimir Potapov 2012-12-26 15:38:33 MSK
x64 in private repo.
Comment 27 Vladimir Potapov 2012-12-26 15:48:45 MSK
(In reply to comment #23)
> Please, try this: change the parameter use_dvdnav from "false" to  "true" in
> the settings ( ~/.config/rosamp/rosamp.ini) and try to use DVD-menu directly
> from the ROMP menu.

DVD menu directly from ROMP work fine, but not play movie from DVD menu. 
Without menu DVD play ok.
Comment 28 Vladimir Potapov 2012-12-26 16:05:26 MSK
Bug with play error from DVD-menu present only one DVD (protected).
All other DVD play fine!!!
Comment 29 Denis Koryavov 2013-04-16 14:16:08 MSD
UP. What we will do with this bug? I suppose, we should publish the last package.
Comment 30 Vladimir Potapov 2013-04-16 14:54:19 MSD
QA Team not received check request....
Comment 31 Denis Silakov 2015-04-02 23:02:04 MSD
This should be fixed in Fresh and in the next version of Enterprise Desktop. No backport for Marathon is planned.