Bug 1145 - [UPDATE REQUEST] [UPSTREAM UPDATE] pango
: [UPDATE REQUEST] [UPSTREAM UPDATE] pango
Status: RESOLVED FIXED
Product: Server Bugs
Classification: ROSA Server
Component: Main Packages
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: Andrew Lukoshko
: ROSA Server Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-03 13:59 MSK by Andrew Lukoshko
Modified: 2012-12-05 00:52 MSK (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrew.lukoshko: published_server+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Lukoshko 2012-12-03 13:59:29 MSK
Update for pango from RHEL6 upstream.

Advisory:

* Due to a regression in the pangoft2 module, an incorrect calculation caused
that the approximate width of a character was reported as zero. Consequently,
some applications using the Pango library failed with an assertion. With this
update, the approximate character width is always set correctly and the failures
no longer occur. 
http://rhn.redhat.com/errata/RHBA-2012-1498.html

Build lists:

https://abf.rosalinux.ru/build_lists/850398
https://abf.rosalinux.ru/build_lists/850399

Please DON'T PUBLISH, just test.
Comment 1 Vladimir Potapov 2012-12-04 16:38:12 MSK
pango-1.28.1-7.res6
****************** RHEL Advisory *****************
Due to a regression in the pangoft2 module, an incorrect calculation caused
that the approximate width of a character was reported as zero. Consequently,
some applications using the Pango library failed with an assertion. With this
update, the approximate character width is always set correctly and the failures
no longer occur. 
**************************************************
QA Verified