Bug 112 - Live installer, wrong resource calculation
: Live installer, wrong resource calculation
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: x86_64 Linux
: Normal enhancement
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-21 18:52 MSD by Nux
Modified: 2012-05-31 12:48 MSD (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
Wrong "low resources" warning (108.76 KB, image/png)
2012-04-21 18:52 MSD, Nux
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nux 2012-04-21 18:52:48 MSD
Created attachment 60 [details]
Wrong "low resources" warning

Description of problem:
The live installer says: "Your system resources are too low".
Screenshot here: http://img.nux.ro/rosalts2-12beta_lowresources.png


Version-Release number of selected component (if applicable):
2012 LTS Beta

How reproducible:
Always
Comment 1 Konstantin Vlasov 2012-04-23 12:59:58 MSD
Cannot reproduce with build 240.
Comment 2 Nux 2012-04-23 14:09:20 MSD
Hi,

Where can I download build 240?
Also, which is the recommended version to test and submit bug reports for?
Comment 3 Konstantin Vlasov 2012-04-23 14:51:15 MSD
(In reply to comment #2)
> Where can I download build 240?
> Also, which is the recommended version to test and submit bug reports for?

http://abf.rosalinux.ru/downloads/rosa2012lts/product/240/ROSA.2012.LTS/iso/ROSA.2012.MARATHON/

There are newer builds, but they might be unofficial and experimental, so the 240th is de-facto what most testers and developers use at the moment.
Comment 4 Nux 2012-04-24 20:18:27 MSD
Hello Konstantin,

Unfortunately build 240 behaves the same way, check this screenshot:
http://img.nux.ro/lowresourcesagain.png
Comment 5 Postnikov Dmitry 2012-04-24 20:52:02 MSD
You run the LiveCD in VirtualBox.

A)Do the following:
1. Install any ISO ROSA in VirtualBox.
2. Start LiveCD in VirtualBOX.
And then you have a system would NOT swear on the unformatted partition /dev/vda

B)Or sdeylayte as follows:
1. Start LiveCD in VirtualBox
2. Make a partition using fdisk /dev/vda
3. Format this partition with mke2fs
4. Restart LiveCD in VirtualBox
And then you have a system would NOT swear on the unformatted partition /dev/vda
Comment 6 Nux 2012-04-24 22:36:54 MSD
Dmitry,

Thanks for clarifying this. In this case I think this warning then creates more trouble than it solves... it should either recognize empty space or just warn about memory. Or remove it altogether.
Comment 7 Postnikov Dmitry 2012-04-24 23:11:15 MSD
The ROSA-Live swears by the empty space, because he needed a swap. A scratch on the swap space is not.
I think the ROSA-Live should not warn about empty space. He has ALL of their data stored in RAM and not use a swap to the Live mode. And in order to have enough RAM to Live mode, it is necessary to run fewer Live mode services. Then it will be enough RAM and it will not require swap space.
Comment 8 Konstantin Vlasov 2012-04-25 20:06:11 MSD
I investigated the problem and found that it was caused by the "vda" disk name (system requirements checker failed to recognize it and thought there were no disks at all). The fix is ready, and in some of the future builds the problem should be fixed.

Thanks for the report.
Comment 9 Konstantin Vlasov 2012-05-31 12:48:19 MSD
The problem is fixed in release ISOs. Closing.