Bug 1101 - Mouse works incorrectly after updates
: Mouse works incorrectly after updates
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-18 16:10 MSK by FirstLevel
Modified: 2013-11-11 10:03 MSK (History)
2 users (show)

See Also:
RPM Package: 3.6.10-nrj-desktop-1rosa
ISO-related:
Bad POT generating:
Upstream:


Attachments
some diagnostic information (785 bytes, text/plain)
2012-11-18 16:10 MSK, FirstLevel
Details
tail -n 100 /var/log/messages after lsusb (10.23 KB, application/octet-stream)
2012-11-18 16:11 MSK, FirstLevel
Details
lsusb-with-power.txt (41.02 KB, text/plain)
2012-12-21 15:46 MSK, FirstLevel
Details
lsusb-on-battery.txt (39.54 KB, text/plain)
2012-12-21 15:47 MSK, FirstLevel
Details
messages-after-unplug-power-cable.txt (8.88 KB, text/plain)
2012-12-21 20:01 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-11-18 16:10:16 MSK
Created attachment 830 [details]
some diagnostic information

Description of problem:
I have mouse Genius Navigator 900x and it works well before latest updates.
After updates one week ago mouse does not work at all.
But if I run lsusb mouse works again.
What should I do to solve my problem
I have attached diagnostic information

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-11-18 16:11:22 MSK
Created attachment 831 [details]
tail -n 100 /var/log/messages after lsusb
Comment 2 FirstLevel 2012-12-21 15:46:09 MSK
Comment on attachment 830 [details]
some diagnostic information

uname -a
Linux localhost.localdomain 3.6.10-nrj-desktop-1rosa #1 SMP PREEMPT Wed Dec 12 13:57:22 UTC 2012 i686 i686 i686 GNU/Linux
Comment 3 FirstLevel 2012-12-21 15:46:28 MSK
Comment on attachment 830 [details]
some diagnostic information

uname -a
Linux localhost.localdomain 3.6.10-nrj-desktop-1rosa #1 SMP PREEMPT Wed Dec 12 13:57:22 UTC 2012 i686 i686 i686 GNU/Linux
Comment 4 FirstLevel 2012-12-21 15:46:52 MSK
Created attachment 945 [details]
lsusb-with-power.txt
Comment 5 FirstLevel 2012-12-21 15:47:05 MSK
Created attachment 946 [details]
lsusb-on-battery.txt
Comment 6 FirstLevel 2012-12-21 15:49:05 MSK
Such situation is occured on 2012.1 Fresh too
I have attached lsusb with plugged power and only with battery.
BTW if laptop switch from plugged power to battery mouse is not functional. But if I execute lsusb - mouse is activating.
Comment 7 Aleksandr Kazantcev 2012-12-21 15:51:01 MSK
in Marathon NOT official supported kernel 3.6.10.

ROSA Desktop.Fresh 2012 release only for last 2 days. It's not support update from Marathon to Fresh without problem.

Has you newest installed system?
Comment 8 FirstLevel 2012-12-21 15:53:22 MSK
(In reply to comment #7)
> in Marathon NOT official supported kernel 3.6.10.
> 
> ROSA Desktop.Fresh 2012 release only for last 2 days. It's not support
> update from Marathon to Fresh without problem.
> 
> Has you newest installed system?

Yes. User has new installation of ROSA 2012.1 Fresh and old error occured.
Comment 9 FirstLevel 2012-12-21 20:01:02 MSK
Created attachment 947 [details]
messages-after-unplug-power-cable.txt
Comment 10 FirstLevel 2012-12-21 20:01:46 MSK
I have attached the output of command
tail -n 100 /var/log/messages
after unplug power cable
Comment 11 Dmitry Mikhirev 2012-12-22 14:50:57 MSK
Is this bug reproducible with final 2012.1 release installation?
Comment 12 FirstLevel 2012-12-23 16:18:11 MSK
(In reply to comment #11)
> Is this bug reproducible with final 2012.1 release installation?

Yes.
Comment 13 FirstLevel 2012-12-23 19:32:14 MSK
This situation is occured for other mouse also. Wireless Logitech М215.
If I unplug power cable - mouse is not working. When I plug power cable again - mouse is working.
It  looks like some power energy saving for USB port.
Comment 14 FirstLevel 2013-01-14 10:53:14 MSK
User has such information (in russian) - solution the problem
"Проблему решил, используя эту инструкцию http://help.ubuntu.ru/wiki/laptop_mode
В /etc/laptop-mode/conf.d/usb-autosuspend.conf добавил строчку AUTOSUSPEND_USBID_BLACKLIST="0458:00b1 0cf3:3004". Чтобы такого не повторялось, предлагаю по умолчанию отключить эту функцию CONTROL_USB_AUTOSUSPEND=0
И в целом нужно пересмотреть настройки laptop-mode-tools, например в /etc/laptop-mode/conf.d/cpufreq.conf попалась вот такая строка- BATT_CPU_GOVERNOR=ondemand. Ondemand как то не очень способствует энергосбережению."
Comment 15 Aleksandr Kazantcev 2013-11-08 23:46:33 MSK
Close as obsolete laptop-mode-tools
Comment 16 FirstLevel 2013-11-11 10:03:59 MSK
(In reply to comment #15)
> Close as obsolete laptop-mode-tools

Could You translate it to human language?