Bug 1091 - [UPDATE REQUEST] [UPSTREAM UPDATE] procps
: [UPDATE REQUEST] [UPSTREAM UPDATE] procps
Status: RESOLVED FIXED
Product: Server Bugs
Classification: ROSA Server
Component: Main Packages
: unspecified
: All Linux
: Normal normal
: ---
Assigned To: Andrew Lukoshko
: ROSA Server Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-15 22:29 MSK by Andrew Lukoshko
Modified: 2012-11-23 16:58 MSK (History)
1 user (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
andrew.lukoshko: published_server+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Lukoshko 2012-11-15 22:29:34 MSK
Update for procps from RHEL6 upstream.

Advisory:
* Prior to this update, the 'si' and 'so' values were always zero for "m" or "M"
units. This was caused by an arithmetic precision loss in the expressions used
for the calculations. This update modifies the expressions to avoid precision
losses.

* Prior to this update, the vmstat tool could be terminated unexpectedly raising
the SIGFPE exception when the total sum of 'us', 'sy', 'id', 'wa' and 'st'
values returned by the kernel was zero. This situation could only appear on
certain specific platforms. this update modifies the internal evaluation so that
the vmstat tool is more robust and does no longer terminate.
http://rhn.redhat.com/errata/RHBA-2012-1463.html

Build lists:
https://abf.rosalinux.ru/build_lists/846512
https://abf.rosalinux.ru/build_lists/846513

Please DON'T PUBLISH, just test.
Comment 1 Vladimir Potapov 2012-11-23 14:51:25 MSK
procps-3.2.8-25.res6
************************ RHEL Advisory *****************
* Prior to this update, the 'si' and 'so' values were always zero for "m" or "M"
units. This was caused by an arithmetic precision loss in the expressions used
for the calculations. This update modifies the expressions to avoid precision
losses.

* Prior to this update, the vmstat tool could be terminated unexpectedly raising
the SIGFPE exception when the total sum of 'us', 'sy', 'id', 'wa' and 'st'
values returned by the kernel was zero. This situation could only appear on
certain specific platforms. this update modifies the internal evaluation so that
the vmstat tool is more robust and does no longer terminate.
**********************************************************
QA Verified