Bug 1074 - "Unsupported hardware" watermark in the right bottom corner of the screen
: "Unsupported hardware" watermark in the right bottom corner of the screen
Status: RESOLVED WONTFIX
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-13 14:02 MSK by FirstLevel
Modified: 2012-12-22 14:56 MSK (History)
3 users (show)

See Also:
RPM Package: dkms-fglrx-8.961-3-rosa.lts2012.0.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments
watermark (264.25 KB, image/jpeg)
2012-11-13 14:02 MSK, FirstLevel
Details
diagnostic information (5.94 KB, text/plain)
2012-11-13 14:02 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-11-13 14:02:04 MSK
Created attachment 824 [details]
watermark

Description of problem:
After installing proprietary driver for my AMD videocard I see "Unsupported hardware" watermark in the right bottom corner of the screen
Screenshot and diagnostic information are attached


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-11-13 14:02:20 MSK
Created attachment 825 [details]
diagnostic information
Comment 2 Aleksandr Kazantcev 2012-11-13 14:09:39 MSK
If you Card is work that's is normal - card simple not in driver base...
You may disable this message by that step:

Put this in a text file and save it (call it fixwatermark.sh):

#!/bin/sh
DRIVER=/usr/lib/fglrx/xorg/modules/drivers/fglrx_drv.so
for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER
done

With terminal go to the location where you saved it and do a

chmod +x fixwatermark.sh
to make it executable and run (from root)

./fixwatermark.sh
to let the script remove the enableLogo
Comment 3 FirstLevel 2012-11-14 19:57:19 MSK
(In reply to comment #2)
> If you Card is work that's is normal - card simple not in driver base...
> You may disable this message by that step:
> 
> Put this in a text file and save it (call it fixwatermark.sh):
> 
> #!/bin/sh
> DRIVER=/usr/lib/fglrx/xorg/modules/drivers/fglrx_drv.so
> for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print
> "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
> sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER
> done
> 
> With terminal go to the location where you saved it and do a
> 
> chmod +x fixwatermark.sh
> to make it executable and run (from root)
> 
> ./fixwatermark.sh
> to let the script remove the enableLogo

It does not work for 64bit systems.
Could we solve the problem by new drivers for videocards from vendors?