Bug 1071 - Cannot update the system or install programs because of incorrect default media address
: Cannot update the system or install programs because of incorrect default med...
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-11 21:49 MSK by mb
Modified: 2013-01-17 08:03 MSK (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mb 2012-11-11 21:49:41 MSK
Description of problem:
I cannot install or update packages because Control Center tries to obtain media sources through an incorrect address:

Unable to add medium, errors reported:

...retrieving failed: curl failed: exited with 6
unable to access the distribution medium (no media.cfg file found)

Medium: LTS2012.0- (http:///downloads/rosa2012lts/repository/)

How reproducible:
1.Delete all media sources or do a fresh install of Marathon 2012
2.Go to Configure Your Computer > Software Management > Update your System
3.After failing in retrieving media sources you get the above error msg

The workaround is to add media manually (I did urpmi.addmedia --distrib http://mirror.yandex.ru/rosa/rosa2012lts/repository/x86_64/).
Comment 1 alexander barakin 2013-01-15 15:01:48 MSK
(In reply to comment #0)
> 1.Delete all media sources or do a fresh install of Marathon 2012
> 2.Go to Configure Your Computer > Software Management > Update your System

wrong!
after removing media sources or fresh install you must add media sources first:
"configure your computer" → "software management" → "configure media sources for install and update" → press button "add".

in my opinion, this is invalid bug-report.
Comment 2 Denis Silakov 2013-01-17 08:03:07 MSK
Alexander is right. Before updating the system, you should add media sources (either through UI or through command line, like you did).

The task of "Update your system" is to install the freshest packages from the medias you have turned on in your system. No medias == no updates.