Bug 1055 - Need to reconfigure printer after restart
: Need to reconfigure printer after restart
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-09 15:12 MSK by FirstLevel
Modified: 2013-09-19 16:30 MSD (History)
5 users (show)

See Also:
RPM Package: hplip-3.12.6-1-rosa.lts2012.0.i586
ISO-related:
Bad POT generating:
Upstream:


Attachments
messages.gz (2.42 KB, application/gzip)
2013-02-04 10:23 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-11-09 15:12:34 MSK
Description of problem:
I have printer HP LaserJet 1018 and I need to to reconfigure printer after restart my system.
I have configured it as follows.
1. Open ROSA CC
2. Open Hardware - Set up printers
3. Plus Sign - Select Device - HP LaserJet 1018 - Connection - USB.
4. After next configurations (name and other) I could to print before reboot.
5. After reboot I plug printer to USB port
6. Try to Print some page
7. Icon of printer appear in the tray with status "Ther is problem while print document"
8. To solve this problem I need to delete and reconfigure my printer again


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-11-10 09:22:42 MSK
[root@mycomp tmp]# cat /etc/cups/printers.conf
# Printer configuration file for CUPS v1.4.8
# Written by cupsd on 2012-11-06 20:57
# DO NOT EDIT THIS FILE WHEN CUPSD IS RUNNING
<DefaultPrinter Hewlett-Packard-HP-LaserJet-1018>
Info Hewlett-Packard HP LaserJet 1018
Location ndsbook.homedomain
MakeModel HP LaserJet 1018 Foomatic/foo2zjs-z1 (recommended)
DeviceURI usb://HP/LaserJet%201018?serial=KP0VSHQ
State Idle
StateTime 1352213845
Type 8425476
Filter application/vnd.cups-raw 0 -
Filter application/vnd.cups-postscript 100 foomatic-rip
Filter application/vnd.cups-pdf 0 foomatic-rip
Filter application/vnd.cups-command 0 commandtops
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
</Printer>
Comment 2 alexander barakin 2012-12-18 20:28:53 MSK
1. can you connect to the cups web-interface http://localhost:631 ?
2. if not, please update package cups (see bug #880 ) and check if your bug is still present.
Comment 3 FirstLevel 2012-12-30 19:47:37 MSK
(In reply to comment #2)
> 1. can you connect to the cups web-interface http://localhost:631 ?
> 2. if not, please update package cups (see bug #880 ) and check if your bug
> is still present.

1. Yes
2. After updating packages (hplip also) the rpoblem with processor utilization by /lib/udev/udev-add-printer  is present
Comment 4 alexander barakin 2013-01-09 17:44:10 MSK
please provide three outputs of command
$ lpstat -s -t

1. right after reboot
2. 10-15 seconds after connecting the printer to the usb port
3. after configuration and successful printing
Comment 5 alexander barakin 2013-01-09 17:50:06 MSK
(In reply to comment #0)
> 5. After reboot I plug printer to USB port

try _not_ to unplug the printer.
bug repeated?
Comment 6 alexander barakin 2013-01-09 17:54:12 MSK
(In reply to comment #3)
> 2. After updating packages (hplip also) the rpoblem with processor
> utilization by /lib/udev/udev-add-printer  is present

this was not mentioned before.
what is written in the logs? (/var/log/messages, /var/log/syslog, /var/log/cups/*, etc.)
Comment 7 FirstLevel 2013-02-04 10:23:42 MSK
(In reply to comment #6)
> (In reply to comment #3)
> > 2. After updating packages (hplip also) the rpoblem with processor
> > utilization by /lib/udev/udev-add-printer  is present
> 
> this was not mentioned before.
> what is written in the logs? (/var/log/messages, /var/log/syslog,
> /var/log/cups/*, etc.)

After updating system problem is not solved.
After plugging printer I need to reconfigure printer again. Test page has printed successfully. I unplug printer and plug again - printer does not print
udev-add-printer task opccupied  100% on one core
I have attached /var/log/messages on messages.gz
Comment 8 FirstLevel 2013-02-04 10:23:55 MSK
Created attachment 1140 [details]
messages.gz
Comment 9 FirstLevel 2013-02-04 21:14:13 MSK
# rpm -qa | grep hplip
hplip-model-data-3.12.6-3-rosa.lts2012.0.i586
hplip-hpijs-3.12.6-3-rosa.lts2012.0.i586
hplip-hpijs-ppds-3.12.6-3-rosa.lts2012.0.i586
hplip-3.12.6-3-rosa.lts2012.0.i586
hplip-gui-3.12.6-3-rosa.lts2012.0.i586
hplip-debug-3.12.6-3-rosa.lts2012.0.i586
Comment 10 FirstLevel 2013-02-04 21:14:44 MSK
I see that http://bugs.rosalinux.ru/show_bug.cgi?id=1582 maybe similar bug
Comment 11 Denis Silakov 2013-08-23 14:41:28 MSD
*** Bug 1582 has been marked as a duplicate of this bug. ***
Comment 12 Denis Silakov 2013-08-26 15:08:22 MSD
Is there anyone who can reproduce this issue with Marathon? Please check the newest hplip package:

https://abf.rosalinux.ru/build_lists/1220729
https://abf.rosalinux.ru/build_lists/1220730
Comment 13 Denis Silakov 2013-09-19 16:30:39 MSD
Ok, we have updated hplip to newer version that solves similar issue for Desktop Fresh. Hopefully this isuue for Marathon is solved, as well.