Bug 1044 - Dovecot hangs on starting and could not be stopped
: Dovecot hangs on starting and could not be stopped
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-02 10:23 MSK by FirstLevel
Modified: 2014-06-03 16:14 MSD (History)
1 user (show)

See Also:
RPM Package: dovecot-1.2.17-2-rosa.lts2012.0.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments
dovecot.conf (5.00 KB, application/octet-stream)
2012-11-02 10:23 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-11-02 10:23:49 MSK
Created attachment 807 [details]
dovecot.conf

Description of problem:
1. Install Dovecot.
2. Execute /etc/init.d/dovecot start
3. It hangs for a long time.
4. While it is hanging You have such output of diagnostic commands:
# systemctl status dovecot.service
dovecot.service - LSB: Dovecot IMAP daemon
          Loaded: loaded (/etc/rc.d/init.d/dovecot)
          Active: activating (start) since Fri, 02 Nov 2012 06:12:07 +0400; 7s ago
         Process: 13751 ExecStart=/etc/rc.d/init.d/dovecot start (code=exited, status=0/SUCCESS)
          CGroup: name=systemd:/system/dovecot.service
                  ├ 13760 dovecot
                  ├ 13762 dovecot-auth
                  ├ 13767 dovecot-auth -w
                  ├ 13771 pop3-login
                  ├ 13772 pop3-login
                  └ 13773 pop3-login

Nov 02 06:12:07 atisot.ru dovecot[13751]: Starting IMAP daemon (dovecot): [ ...]
# ps aux | grep dovecot
root     13734  0.0  0.0  24976  1724 pts/3    S+   06:12   0:00 /bin/bash /etc/init.d/dovecot start
root     13749  0.0  0.0  19692  1032 pts/3    S+   06:12   0:00 /bin/systemctl start dovecot.service
root     13760  0.0  0.0   6608   728 ?        Ss   06:12   0:00 dovecot
mail     13762  0.0  0.0 109844  2192 ?        S    06:12   0:00 dovecot-auth
mail     13767  0.0  0.0 109968  2640 ?        S    06:12   0:00 dovecot-auth -w
root     14484  0.0  0.0  22208   856 pts/2    S+   06:12   0:00 grep --color dovecot

5. When in unfreeze You see:
# systemctl status dovecot.service
dovecot.service - LSB: Dovecot IMAP daemon
          Loaded: loaded (/etc/rc.d/init.d/dovecot)
          Active: failed since Fri, 02 Nov 2012 06:17:07 +0400; 24s ago
         Process: 13751 ExecStart=/etc/rc.d/init.d/dovecot start (code=exited, status=0/SUCCESS)
          CGroup: name=systemd:/system/dovecot.service
                  ├ 13760 dovecot
                  ├ 13762 dovecot-auth
                  ├ 13767 dovecot-auth -w
                  ├ 13771 pop3-login
                  ├ 13772 pop3-login
                  └ 13773 pop3-login

Nov 02 06:12:07 atisot.ru dovecot[13751]: Starting IMAP daemon (dovecot): [ ...]
# ps aux | grep dovecot
root     13760  0.0  0.0   6608   728 ?        Ss   06:12   0:00 dovecot
mail     13762  0.0  0.0 109844  2192 ?        S    06:12   0:00 dovecot-auth
mail     13767  0.0  0.0 109968  2640 ?        S    06:12   0:00 dovecot-auth -w
root     25265  0.0  0.0  22212   856 pts/2    S+   06:17   0:00 grep --color dovecot

6. If You stop it with /etc/init.d/dovecot stop it does not stop and it is necessary to kill processes.

Resume:
I think dovecot could not fully integrated with systemd.





Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Dmitry Mikhirev 2012-12-20 15:45:16 MSK
(In reply to comment #0)

> 6. If You stop it with /etc/init.d/dovecot stop it does not stop and it is
> necessary to kill processes.
> 

Try using

 # systemctl stop dovecot.service

command instead
Comment 2 FirstLevel 2012-12-20 17:13:38 MSK
(In reply to comment #1)
> (In reply to comment #0)
> 
> > 6. If You stop it with /etc/init.d/dovecot stop it does not stop and it is
> > necessary to kill processes.
> > 
> 
> Try using
> 
>  # systemctl stop dovecot.service
> 
> command instead

User has answered that service has not stopped after this command
Comment 3 FirstLevel 2014-03-19 10:16:23 MSK
case is actual for
[root@ltsx32kde ~]# rpm -qa | grep dovecot
dovecot-1.2.17-2-rosa.lts2012.0.i586
Comment 4 FirstLevel 2014-06-03 16:10:16 MSD
checking the relevance