Bug 1042 - mc is crashed after change ownership by "ctrl+x o"
: mc is crashed after change ownership by "ctrl+x o"
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on: 1051
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-01 21:10 MSK by FirstLevel
Modified: 2012-12-20 15:47 MSK (History)
3 users (show)

See Also:
RPM Package: mc-4.8.3-2-rosa.lts2012.0.x86_64
ISO-related:
Bad POT generating:
Upstream: known


Attachments
crash (103.73 KB, image/jpeg)
2012-11-01 21:10 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-11-01 21:10:49 MSK
Created attachment 806 [details]
crash

Description of problem:
Open konsole and run mc from the root user.
Select object (file or directory) and press ctrl+x o.
Choose new owner and click "Apply" (Установить)
MC is crashed with log like on the attachment


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-11-01 21:20:22 MSK
It is actual for ordinary users and root too.
Comment 2 Eugene Shatokhin 2012-11-06 11:59:34 MSK
I have reproduced the problem too.

mc crashes with the following backtrace:

----------------------------
#0  0x00007ffff722b1d5 in raise () from /lib64/libc.so.6
#1  0x00007ffff722c75b in abort () from /lib64/libc.so.6
#2  0x00007ffff72648f3 in __libc_message () from /lib64/libc.so.6
#3  0x00007ffff726a6f6 in malloc_printerr () from /lib64/libc.so.6
#4  0x00007ffff759a53e in g_array_free (farray=0x7a5ba0, free_segment=<value optimized out>) at garray.c:303
#5  0x0000000000453f87 in vfs_path_free (vpath=0x7d0ca0) at path.c:948
#6  0x0000000000496c42 in chown_cmd () at chown.c:381
#7  0x000000000047d5f3 in midnight_execute_cmd (sender=0x0, command=26) at midnight.c:1094
#8  0x0000000000448944 in dlg_key_event (h=0x79a560, key=111, event=0x7fffffffd8f0) at dialog.c:499
#9  dlg_process_event (h=0x79a560, key=111, event=0x7fffffffd8f0) at dialog.c:1251
#10 0x0000000000448f74 in frontend_run_dlg (h=0x79a560) at dialog.c:562
#11 run_dlg (h=0x79a560) at dialog.c:1283
#12 0x000000000047eb66 in create_panels_and_run_mc () at midnight.c:922
#13 do_nc () at midnight.c:1696
#14 0x000000000040f9d5 in main (argc=1, argv=0x7fffffffdba8) at main.c:567
----------------------------

Looks like some glib2 array is used in an incorrect way. I'm currently digging into this problem.
Comment 3 Eugene Shatokhin 2012-11-06 12:14:10 MSK
Looks like it is a known problem and is fixed in upstream:
https://www.midnight-commander.org/ticket/2784

The fix looks rather simple, I'll check if it works.
Comment 4 Eugene Shatokhin 2012-11-07 11:34:12 MSK
The patch works for me.

I have proposed an update of mc to the version 4.8.6 that has this fix along with other important fixes:
http://bugs.rosalinux.ru/show_bug.cgi?id=1051