Bug 1041 - System-config-printer not start CUPS after configure printers
: System-config-printer not start CUPS after configure printers
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: 2012 Desktop RC
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
: 2012.1
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-31 23:43 MSK by Aleksandr Kazantcev
Modified: 2013-09-17 09:57 MSD (History)
4 users (show)

See Also:
RPM Package: system-config-printers
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksandr Kazantcev 2012-10-31 23:43:13 MSK
http://mib.pianetalinux.org/forum/viewtopic.php?p=20077&sid=7e52b6f5184c0570e925a00b03e878dc#p20077

i had some troubles installing my first printer(hp 8600 aio)

hp-setup find the printer, but can not comunicate with it.


so i tried with mcc->system-config-printer. the configuration tool ask me for connect with cups server. i responded yes, but cups won't start.

i start cups manually and finally, after that task-printing-server and task-printing-hp were intalled by system-config-printer, my printer works.

so:
- hplip is installed, but without task-printing-hp and task-printing-server is impossible to configure printers
- system-config-printer is not able to start cups service
Comment 1 Denis Silakov 2012-10-31 23:58:42 MSK
I think this is similar to bug #950 - it seems that after migration to systemd, system-config-printer can't launch cups...
Comment 2 alexander barakin 2012-12-14 17:15:42 MSK
maybe related: bug #880

cups does not listen to port ipp (631) because port blocked by portreserve.service
Comment 3 Denis Silakov 2012-12-22 20:17:23 MSK
*** Bug 950 has been marked as a duplicate of this bug. ***
Comment 4 Stanislav Fomin 2013-09-17 02:03:19 MSD
No comments last year, this is obviously not a blocker.

Alex, is this bug is still active?