Bug 1038 - urpm-reposync: crashes (clone of #1030 for Marathon)
: urpm-reposync: crashes (clone of #1030 for Marathon)
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-31 14:35 MSK by Anton Kirilenko
Modified: 2012-11-14 13:39 MSK (History)
2 users (show)

See Also:
RPM Package: urpm-tools-2.1-0
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Kirilenko 2012-10-31 14:35:14 MSK
Description of problem:

the same behavior can be encountered in ROSA Marathon. The new version fixes that (as it was tested in #1030)
Comment 1 Anton Kirilenko 2012-10-31 14:37:33 MSK
Advisory:
Conflicts resolving in urpm-reposync have been improved.

x86_64: https://abf.rosalinux.ru/build_lists/840847
i586:   https://abf.rosalinux.ru/build_lists/840842
Comment 2 Vladimir Potapov 2012-11-08 10:41:09 MSK
I can't reproduce this bug.
urpmi urpm-tools
Пакет urpm-tools-2.2-1-rosa.lts2012.0.noarch уже установлен
[root@ROSA keleg]# urpm-reposync
Загрузка списка установленных пакетов...
Обработка источника main (distrib1)...
Обработка источника main updates (distrib2)...
Обработка источника non-free (distrib5)...
Обработка источника non-free updates (distrib6)...
Обработка источника restricted (distrib7)...
Обработка источника restricted updates (distrib8)...
Обработка источника QT...
Обработка источника urpm-tools...
Обработка источника qstyle...
Computing actions list...
Версии следующих пакетов будут понижены:
 Имя пакета             Текущая версия  Новая версия Архитектура
(источник  main (distrib1))
 drakx-net                       0.96-6           0.96-5          noarch    
 drakx-net-text                  0.96-6           0.96-5          noarch    
 lib64pcap1                      1.3.0-1          1.1.1-5         x86_64    
 libdrakx-net                    0.96-6           0.96-5          noarch    

Пакетов будет скачано и установлено: 4.
Пакетов будет удалено: 0.
Данных будет скачано: 5.28M.
Хотите продолжить? (д/н): д
Скачивание файлов...
[1/4] drakx-net-0.96-5-rosa.lts2012.0.noarch.rpm 
[2/4] libdrakx-net-0.96-5-rosa.lts2012.0.noarch.rpm 
[3/4] drakx-net-text-0.96-5-rosa.lts2012.0.noarch.rpm 
[4/4] lib64pcap1-1.1.1-5-rosa.lts2012.0.x86_64.rpm 
Создание транзакции...
Проверка зависимостей...
Ошибок не найдено
Запуск транзакции...
[1/4] libdrakx-net-0.96-5-rosa.lts2012.0.noarch.rpm
[2/4] lib64pcap1-1.1.1-5-rosa.lts2012.0.x86_64.rpm
[3/4] drakx-net-text-0.96-5-rosa.lts2012.0.noarch.rpm
Удаление lib64pcap1
[4/4] drakx-net-0.96-5-rosa.lts2012.0.noarch.rpm
Удаление drakx-net
Удаление drakx-net-text
Удаление libdrakx-net
Comment 3 Anton Kirilenko 2012-11-08 12:47:03 MSK
As I wrote before, this behavior CAN BE encountered. With specific packages installed and in repository, this bug will occur as in 2012 Desktop (it's no matter what the distribution is, reposync works the same way). So, to prevent errors, publish this update please.
Comment 4 Vladimir Potapov 2012-11-12 12:46:31 MSK
urpm-tools  2.1-2-rosa.lts2012.0
************** advisory **********
Conflicts resolving in urpm-reposync have been improved.
**********************************
QA Verified