Bug 1035 - Dracut error at system boot.
: Dracut error at system boot.
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-31 01:25 MSK by Alexander Petryakov
Modified: 2012-12-20 15:53 MSK (History)
2 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
dracut error (770.14 KB, image/jpeg)
2012-10-31 01:25 MSK, Alexander Petryakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Petryakov 2012-10-31 01:25:23 MSK
Created attachment 801 [details]
dracut error

Description of problem:
The problem same that in http://bugs.rosalinux.ru/show_bug.cgi?id=424 only for ROSA.2012.Desktop.Beta1.x86_64.iso 


workaround (http://wiki.rosalab.ru/en/index.php/Booting_ROSA_from_iso_file) don't work too.
./rosa-fromiso ./rosa.iso ./rosa_initrd
91395 блок
patching file init
Hunk #1 succeeded at 335 with fuzz 1 (offset -104 lines).
can't find file to patch at input line 19
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -Naur a/lib/dracut/hooks/pre-udev/30dmsquash-liveiso-genrules.sh b/lib/dracut/hooks/pre-udev/30dmsquash-liveiso-genrules.sh
|--- a/lib/dracut/hooks/pre-udev/30dmsquash-liveiso-genrules.sh 2012-03-20 16:30:32.072406888 +1100
|+++ b/lib/dracut/hooks/pre-udev/30dmsquash-liveiso-genrules.sh 2012-03-20 02:00:36.163756463 +1100
--------------------------
File to patch: ^C


How reproducible:


Steps to Reproduce:
1. Prepair usbflash (dd if=ISO of=/dev/sdX bs=1M
2. boot from usbflash
3. select start live (1 or 3) 
4. dracut error (see attachement)
Comment 1 Aleksandr Kazantcev 2012-10-31 01:38:27 MSK
try

dd if=ISO of=/dev/sdX bs=8M
Comment 2 Alexander Burmashev 2012-12-20 15:53:17 MSK
Closing the bug since it is filled against Beta/Alpha, please reopen it if it is still valid