Bug 1033 - Strange output of df
: Strange output of df
Status: RESOLVED DUPLICATE of bug 374
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-30 14:50 MSK by FirstLevel
Modified: 2012-12-18 20:20 MSK (History)
3 users (show)

See Also:
RPM Package:
ISO-related:
Bad POT generating:
Upstream:


Attachments
Diagnostic information (2.59 KB, text/plain)
2012-10-30 14:50 MSK, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-10-30 14:50:32 MSK
Created attachment 800 [details]
Diagnostic information

Description of problem:
I have such disk configuration:
# fdisk -l

Disk /dev/sda: 160.0 GB, 160040803840 bytes
255 heads, 63 sectors/track, 19457 cylinders, всего 312579695 секторов
Units = секторы of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x8a0a3a6c

Устр-во Загр     Начало       Конец       Блоки   Id  Система
/dev/sda1   *        2048    25189919    12593936   83  Linux
/dev/sda2        25192440   312576704   143692132+   5  Расширенный
/dev/sda5        25192448    33367004     4087278+  82  Linux своп / Solaris
/dev/sda6        33370112   312576704   139603296+  83  Linux

If I run df command I get strange strings in the top:
# df
df: «/sys/fs/fuse/connections»: Нет такого файла или каталога
df: «/sys/fs/fuse/connections»: Нет такого файла или каталога
df: «/sys/fs/fuse/connections»: Нет такого файла или каталога
Файловая система Размер Использовано  Дост Использовано% Cмонтировано в
/dev/sda1           12G         4,9G  6,4G           44% /
/dev/sda6          132G         958M  131G            1% /home
/dev/sda6          132G         958M  131G            1% /home
/dev/sda6          132G         958M  131G            1% /home
/dev/sda6          132G         958M  131G            1% /home
/dev/sda6          132G         958M  131G            1% /home
/dev/sda6          132G         958M  131G            1% /home
/dev/sda6          132G         958M  131G            1% /home
/dev/sda6          132G         958M  131G            1% /home
/dev/sda6          132G         958M  131G            1% /home

I have attached some diagnostic information


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Aleksandr Kazantcev 2012-10-30 14:52:59 MSK
rm -rf /etc/mtab
ln -s /proc/self/mounts /etc/mtab

*** This bug has been marked as a duplicate of bug 374 ***
Comment 2 FirstLevel 2012-10-31 12:39:16 MSK
User has told that problem is not solved and he has such output if df command after applying recomendation

# df
Файловая система Размер Использовано  Дост Использовано% Cмонтировано в
rootfs              12G         4,9G  6,4G           44% /
devtmpfs           3,9G            0  3,9G            0% /dev
tmpfs              3,9G            0  3,9G            0% /dev/shm
tmpfs              3,9G         3,1M  3,9G            1% /run
/dev/sda1           12G         4,9G  6,4G           44% /
tmpfs              3,9G         3,1M  3,9G            1% /run
tmpfs              3,9G            0  3,9G            0% /sys/fs/cgroup
tmpfs              3,9G            0  3,9G            0% /media
/dev/sda6          132G         990M  131G            1% /home
Comment 3 Aleksandr Kazantcev 2012-10-31 12:48:03 MSK
Last output is normal - what's wrong for user?
Comment 4 FirstLevel 2012-10-31 12:58:54 MSK
(In reply to comment #3)
> Last output is normal - what's wrong for user?

many tmpfs items are correct?
And duplicate like this
tmpfs              3,9G         3,1M  3,9G            1% /run
Comment 5 Aleksandr Kazantcev 2012-10-31 13:03:23 MSK
Yes, for version programm in Marathon is correct.
Comment 6 FirstLevel 2012-10-31 13:08:07 MSK
(In reply to comment #5)
> Yes, for version programm in Marathon is correct.

I can't understand Your answer? The output maybe correct or incorrect at all.
Comment 7 Aleksandr Kazantcev 2012-10-31 13:09:27 MSK
Yes, it's correct. tmpfs is a part of local fs.
Comment 8 FirstLevel 2012-10-31 16:00:48 MSK
(In reply to comment #7)
> Yes, it's correct. tmpfs is a part of local fs.

An answer of user on the question "What is strange"?
1. "tmpfs 3,9G 3,1M 3,9G 1% /run" - are duplicated
2. He expected for 
Файловая система Размер Использовано Дост Использовано% Cмонтировано в
/dev/sda1 12G 4,9G 6,4G 44% /
/dev/sda6 132G 990M 131G 1% /home
Comment 9 alexander barakin 2012-12-18 20:20:08 MSK
(In reply to comment #8)
> 2. He expected for 

$ df -t ext4
Comment 10 alexander barakin 2012-12-18 20:20:40 MSK

*** This bug has been marked as a duplicate of bug 374 ***