Bug 1031 - ROMP subtitles decoding fail
: ROMP subtitles decoding fail
Status: RESOLVED DUPLICATE of bug 1154
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: Julia Mineeva
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-30 12:08 MSK by Vladimir Potapov
Modified: 2013-02-12 12:16 MSK (History)
2 users (show)

See Also:
RPM Package: rosa-media-player
ISO-related:
Bad POT generating:
Upstream:


Attachments
wrong (453.64 KB, image/png)
2012-10-30 12:08 MSK, Vladimir Potapov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Potapov 2012-10-30 12:08:03 MSK
Created attachment 798 [details]
wrong

Description of problem:
The ROMP subtitles decoding fail

See screenshot
Comment 1 Julia Mineeva 2012-10-30 12:56:04 MSK
ROMP does not automatically detects the encoding of subtitles.
To view the subtitles should select the encoding in the "Preferneces" - "Subtitles" window (the default is UTF-8).
Comment 2 Vladimir Potapov 2012-10-30 15:30:35 MSK
But kwrite detect this files normally... It is cp1251.
Comment 3 Denis Koryavov 2012-10-30 18:32:56 MSK
As far as I can understood KWrite has an option for automatic encoding detection for Russian language, but ROMP don't. Try to change encoding  in ROMP for subtitles to cp1251 and if everything will be normal, then this is not a bug.
Comment 4 Denis Silakov 2012-10-31 13:41:02 MSK
Maybe consider this as a feature request then - teach ROMP to automatically detect subtitle encoding?
Comment 5 Denis Koryavov 2012-10-31 21:32:31 MSK
Well, we can try, but I doubt that we can do this normally for all supported languages.
Comment 6 Denis Silakov 2013-02-12 12:16:38 MSK

*** This bug has been marked as a duplicate of bug 1154 ***