Bug 1030 - urpm-reposync: crashes
: urpm-reposync: crashes
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: All Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-29 16:20 MSK by Dmitry
Modified: 2012-10-31 00:46 MSK (History)
1 user (show)

See Also:
RPM Package: urpm-tools
ISO-related:
Bad POT generating:
Upstream:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry 2012-10-29 16:20:11 MSK
Description of problem:

# urpm-reposync 
Загрузка списка установленных пакетов...
Обработка источника main (Desktop2012.1-1)...
Обработка источника main updates (Desktop2012.1-2)...
Обработка источника contrib (Desktop2012.1-3)...
Обработка источника contrib updates (Desktop2012.1-4)...
Обработка источника non-free (Desktop2012.1-5)...
Обработка источника non-free updates (Desktop2012.1-6)...
Обработка источника restricted (Desktop2012.1-7)...
Обработка источника restricted updates (Desktop2012.1-8)...
Computing actions list...
Traceback (most recent call last):
  File "/usr/bin/urpm-reposync", line 1332, in <module>
    Main()
  File "/usr/bin/urpm-reposync", line 1214, in Main
    process_packages()
  File "/usr/bin/urpm-reposync", line 818, in process_packages
    emulate_remove(act, updating=True)
  File "/usr/bin/urpm-reposync", line 743, in emulate_remove
    deps = installed.packages[pkg][tag]
KeyError: 'provides'
Comment 1 Anton Kirilenko 2012-10-29 19:52:44 MSK
Works for me... could you specify the urpm-tools version please?
Comment 2 Dmitry 2012-10-29 21:35:00 MSK
2.2-1
Comment 3 Anton Kirilenko 2012-10-30 13:58:04 MSK
I encountered the same problem in ROSA 2012 Desktop Alpha2... It will be fixed soon.
Comment 4 Anton Kirilenko 2012-10-30 18:48:11 MSK
An incorrect conflicts resolving caused the problem, it was fixed. The new version (2.2.1) should work well. It's build for ROSA 2012 Desktop x86_64 now (there is a big queue for i586 on ABF). Please, try it and report if the problem is resolved, I'll build it for Marathon.
Comment 5 Dmitry 2012-10-30 22:47:29 MSK
(In reply to comment #4)
> An incorrect conflicts resolving caused the problem, it was fixed. The new
> version (2.2.1) should work well. It's build for ROSA 2012 Desktop x86_64
> now (there is a big queue for i586 on ABF). Please, try it and report if the
> problem is resolved, I'll build it for Marathon.

Desktop 2012.1 x86_64 — fixed.
Comment 6 Anton Kirilenko 2012-10-31 00:46:06 MSK
Good news. Thanx.