Bug 1027 - Could not launch blender
: Could not launch blender
Status: RESOLVED WORKSFORME
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Fresh
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-29 13:04 MSK by FirstLevel
Modified: 2016-01-16 21:10 MSK (History)
4 users (show)

See Also:
RPM Package: blender-2.64-3-rosa.lts2012.0.x86_64
ISO-related:
Bad POT generating:
Upstream:


Attachments
blender-crash.txt (42.12 KB, text/plain)
2015-04-15 15:58 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-10-29 13:04:04 MSK
Description of problem:
Could not launch blender. After start it is crashed with error
bash-4.2$ blender
Info: Config directory with "startup.blend" file not found.
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
LookupError: no codec search functions registered: can't find encoding
Аварийный останов (слепок снят)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Denis Silakov 2013-01-21 14:35:28 MSK
The error was observed if blender was running with some non-English locales.

Updated blender in Marathon to 2.64, this version should work fine.
Comment 2 Jose Martínez 2013-08-23 11:50:12 MSD
Hello everybody.

Blender 2.64 doesn´t work.

It´s the same case as blender 2.58.

My systems are:

- Acer AX3812, 5GB RAM, NVIDIA GeFORCE 310 and Rosa Marathon X1 x86_x64. Only official repos x64, all system updated and nvidia propietary driver 295.40. The system works in Spanish Locales.

- My other machine it´s an Acer Laptop with 2GB RAM and the system is Marathon X1 x86, with only official repos and with all updates and propietary drivers. The system works in Spanish Locales.

Thanks
Comment 3 Jose Martínez 2013-08-23 12:47:36 MSD
Hello everybody.

Blender 2.64 doesn´t work.

It´s the same case as blender 2.58.

My systems are:

- Acer AX3812, 5GB RAM, NVIDIA GeFORCE 310 and Rosa Marathon X1 x86_x64. Only official repos x64, all system updated and nvidia propietary driver 295.40. The system works in Spanish Locales.

- My other machine it´s an Acer Laptop with 2GB RAM and the system is Marathon X1 x86, with only official repos and with all updates and propietary drivers. The system works in Spanish Locales.

Thanks
Comment 4 Denis Silakov 2013-10-03 10:15:29 MSD
*** Bug 2734 has been marked as a duplicate of this bug. ***
Comment 5 Jose Martínez 2013-10-11 15:08:20 MSD
Launching blender with konsole I can see this output:


[ax3812@localhost ~]$ blender
AL lib: pulseaudio.c:331: PulseAudio returned minreq > tlength/2; expect break up
Fatal Python error: Py_Initialize: Unable to get the locale encoding
LookupError: no codec search functions registered: can't find encoding
Abortado (`core' generado)
[ax3812@localhost ~]$ 

Thanks!
Comment 6 Denis Silakov 2013-10-17 14:54:48 MSD
(In reply to comment #5)
> Launching blender with konsole I can see this output:
> 
> 
> [ax3812@localhost ~]$ blender
> AL lib: pulseaudio.c:331: PulseAudio returned minreq > tlength/2; expect
> break up
> Fatal Python error: Py_Initialize: Unable to get the locale encoding
> LookupError: no codec search functions registered: can't find encoding
> Abortado (`core' generado)
> [ax3812@localhost ~]$ 
> 
> Thanks!

Doe it work to launch blender in the following way:

$ LC_ALL=C blender

?
Comment 7 Jose Martínez 2013-10-20 19:29:59 MSD
Here is the output:

[ax3812@localhost ~]$ LC_ALL=C blender
AL lib: pulseaudio.c:331: PulseAudio returned minreq > tlength/2; expect break up
Fatal Python error: Py_Initialize: Unable to get the locale encoding
LookupError: no codec search functions registered: can't find encoding
Abortado (`core' generado)
[ax3812@localhost ~]$ 


Thanks a lot!
Comment 8 FirstLevel 2014-03-19 15:12:25 MSK
Case is actual for latest updates
Comment 9 Jose Martínez 2014-06-07 22:00:37 MSD
OK, thanks.
I really appreciate your effort and I love your distro. 
When will be available next iso of ROSA MARATHON?
Comment 10 Denis Silakov 2014-06-18 01:12:35 MSD
(In reply to comment #9)
> OK, thanks.
> I really appreciate your effort and I love your distro. 
> When will be available next iso of ROSA MARATHON?

Not in the near future, currently we are concentrated on the new ROSA Fresh release.
Comment 11 Stanislav Fomin 2015-03-06 19:35:27 MSK
Need restesting before releasing Enterprise X2.
Comment 12 Jose Martínez 2015-03-10 11:08:52 MSK
I'm sorry but I can't retest because my old acer x3812 was broken two months ago. Now I'm using another machine with Rosa Fresh R5.
With the next iso I'll return to Marathon.
Comment 13 Denis Silakov 2015-03-12 00:11:03 MSK
The next iso will be based on current R5, so if blender works fine in Fresh R5 for you, then everything should be fine in Enterprise X2.
Comment 14 Jose Martínez 2015-03-25 14:56:59 MSK
All is working fine in my Fresh R5, when will be released the next Entrerprise X2 iso?
Thanks
Comment 15 Denis Silakov 2015-03-25 14:57:39 MSK
ISO is planned for end of April/beginning of May.
Comment 16 Jose Martínez 2015-03-26 15:43:41 MSK
Thanks. 
I really appreciate your effort and love your distros.
I'll be waiting like a child for a new toy!!
Regards from Spain
Comment 17 FirstLevel 2015-04-14 22:47:15 MSD
For 32bit RED X2 and Fresh I have such issue while launching blender. It starts with black screen - blender-launch.png
In konsole I see 
sergeired@red32 ~ $ blender
Color management: using fallback mode for management
*** Error in `/usr/bin/blender.sse': free(): corrupted unsorted chunks: 0x0bb11560 ***
*** Error in `/usr/bin/blender.sse': corrupted double-linked list: 0x0bb11a40 ***
Comment 18 Denis Silakov 2015-04-15 13:31:01 MSD
Which hardware do you use?
Comment 19 FirstLevel 2015-04-15 15:58:05 MSD
(In reply to comment #18)
> Which hardware do you use?

For 64bit Fresh blender works well.
Today for 32bit Fresh blender is crashed - blender-crash.txt
Comment 20 FirstLevel 2015-04-15 15:58:18 MSD
Created attachment 3897 [details]
blender-crash.txt
Comment 21 FirstLevel 2015-04-15 15:58:40 MSD
sergei-32@r5-32 ~]$ uname -a
Linux r5-32 3.14.33-nrj-desktop-1rosa #1 SMP PREEMPT Wed Feb 11 09:34:43 UTC 2015 i686 i686 i686 GNU/Linux
[sergei-32@r5-32 ~]$ lspcidrake 
bcma            : Broadcom Corporation|BCM4313 802.11bgn Wireless Network Adapter [NETWORK_OTHER] (rev: 01)
sdhci_pci       : JMicron Technology Corp.|Standard SD Host Controller (rev: 30)
sdhci_pci       : JMicron Technology Corp.|SD/MMC Host Controller [SYSTEM_OTHER] (rev: 30)
firewire_ohci   : JMicron Technology Corp.|IEEE 1394 Host Controller [SERIAL_FIREWIRE] (rev: 30)
r8169           : Realtek Semiconductor Co., Ltd.|RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [NETWORK_ETHERNET] (rev: 06)
unknown         : Advanced Micro Devices, Inc. [AMD]|Family 12h/14h Processor Function 7 [BRIDGE_HOST]
unknown         : Advanced Micro Devices, Inc. [AMD]|Family 12h/14h Processor Function 5 [BRIDGE_HOST]
unknown         : Advanced Micro Devices, Inc. [AMD]|Family 12h/14h Processor Function 6 [BRIDGE_HOST]
unknown         : Advanced Micro Devices, Inc. [AMD]|Family 12h/14h Processor Function 4 [BRIDGE_HOST]
k10temp         : Advanced Micro Devices, Inc. [AMD]|Family 12h/14h Processor Function 3 [BRIDGE_HOST]
unknown         : Advanced Micro Devices, Inc. [AMD]|Family 12h/14h Processor Function 2 [BRIDGE_HOST]
unknown         : Advanced Micro Devices, Inc. [AMD]|Family 12h/14h Processor Function 1 [BRIDGE_HOST]
unknown         : Advanced Micro Devices, Inc. [AMD]|Family 12h/14h Processor Function 0 [BRIDGE_HOST] (rev: 43)
ehci_pci        : Advanced Micro Devices, Inc. [AMD]|FCH USB EHCI Controller [SERIAL_USB] (rev: 11)
ohci_pci        : Advanced Micro Devices, Inc. [AMD]|FCH USB OHCI Controller [SERIAL_USB] (rev: 11)
shpchp          : Advanced Micro Devices, Inc. [AMD]|Hudson PCI to PCI bridge (PCIE port 0) [BRIDGE_PCI]
ohci_pci        : Advanced Micro Devices, Inc. [AMD]|FCH USB OHCI Controller [SERIAL_USB] (rev: 11)
unknown         : Advanced Micro Devices, Inc. [AMD]|FCH PCI Bridge [BRIDGE_PCI] (rev: 40)
unknown         : Advanced Micro Devices, Inc. [AMD]|FCH LPC Bridge [BRIDGE_ISA] (rev: 11)
snd_hda_intel   : Advanced Micro Devices, Inc. [AMD]|FCH Azalia Controller [MULTIMEDIA_AUDIO_DEV] (rev: 01)
i2c_piix4       : Advanced Micro Devices, Inc. [AMD]|FCH SMBus Controller [SERIAL_SMBUS] (rev: 13)
ehci_pci        : Advanced Micro Devices, Inc. [AMD]|FCH USB EHCI Controller [SERIAL_USB] (rev: 11)
ohci_pci        : Advanced Micro Devices, Inc. [AMD]|FCH USB OHCI Controller [SERIAL_USB] (rev: 11)
ehci_pci        : Advanced Micro Devices, Inc. [AMD]|FCH USB EHCI Controller [SERIAL_USB] (rev: 11)
ohci_pci        : Advanced Micro Devices, Inc. [AMD]|FCH USB OHCI Controller [SERIAL_USB] (rev: 11)
unknown         : Advanced Micro Devices, Inc. [AMD]|FCH SATA Controller [AHCI mode] [STORAGE_SATA] (rev: 40)
shpchp          : Advanced Micro Devices, Inc. [AMD]|Family 12h Processor Root Port [BRIDGE_PCI]
shpchp          : Advanced Micro Devices, Inc. [AMD]|Family 12h Processor Root Port [BRIDGE_PCI]
shpchp          : Advanced Micro Devices, Inc. [AMD]|Family 12h Processor Root Port [BRIDGE_PCI]
snd_hda_intel   : Advanced Micro Devices, Inc. [AMD/ATI]|BeaverCreek HDMI Audio [Radeon HD 6500D and 6400G-6600G series] [MULTIMEDIA_AUDIO_DEV]
Card:AMD Radeon (radeon/fglrx): Advanced Micro Devices, Inc. [AMD/ATI]|Sumo [Radeon HD 6480G] [DISPLAY_VGA]
unknown         : Advanced Micro Devices, Inc. [AMD]|Family 12h Processor Root Complex [BRIDGE_HOST]
hub             : Linux 3.14.33-nrj-desktop-1rosa ohci_hcd|OHCI PCI host controller [Hub|Unused|Full speed (or root) hub]
hub             : Linux 3.14.33-nrj-desktop-1rosa ohci_hcd|OHCI PCI host controller [Hub|Unused|Full speed (or root) hub]
hub             : Linux 3.14.33-nrj-desktop-1rosa ohci_hcd|OHCI PCI host controller [Hub|Unused|Full speed (or root) hub]
hub             : Linux 3.14.33-nrj-desktop-1rosa ohci_hcd|OHCI PCI host controller [Hub|Unused|Full speed (or root) hub]
btusb           : Broadcom Corp|HP Integrated Module [Wireless|Radio Frequency|Bluetooth]
hub             : Linux 3.14.33-nrj-desktop-1rosa ehci_hcd|EHCI Host Controller [Hub|Unused|Full speed (or root) hub]
hub             : Linux 3.14.33-nrj-desktop-1rosa ehci_hcd|EHCI Host Controller [Hub|Unused|Full speed (or root) hub]
hub             : Linux 3.14.33-nrj-desktop-1rosa ehci_hcd|EHCI Host Controller [Hub|Unused|Full speed (or root) hub]
[sergei-32@r5-32 ~]$
Comment 22 Denis Silakov 2015-06-30 17:26:36 MSD
This is completely different issue caused by segfault in fglrx driver. Maybe this will be fixed by fglrx update. As a workaround, you can try to use free radeon driver.