Bug 1015 - hp-toolbox could not start
: hp-toolbox could not start
Status: RESOLVED FIXED
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: All Linux
: Normal normal
: ---
Assigned To: Dmitry Mikhirev
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-25 13:11 MSD by FirstLevel
Modified: 2013-01-09 21:00 MSK (History)
4 users (show)

See Also:
RPM Package: hplip-gui-3.12.6-1-rosa.lts2012.0.i586
ISO-related:
Bad POT generating:
Upstream:
vladimir.potapov: qa_verified+
alex.burmashev: published+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-10-25 13:11:24 MSD
Description of problem:
I have ROSA 2012 LTS (3.0.38-nrj-desktop-1rosa.lts ROSA Linux release 2012.0 (LTS) for i586)
with such packages
hplip-gui-3.12.6-1-rosa.lts2012.0.i586
hplip-model-data-3.12.6-1-rosa.lts2012.0.i586
hplip-hpijs-3.12.6-1-rosa.lts2012.0.i586
hplip-hpijs-ppds-3.12.6-1-rosa.lts2012.0.i586
hplip-3.12.6-1-rosa.lts2012.0.i586
hplip-debug-3.12.6-1-rosa.lts2012.0.i586
libhpip0-3.12.6-1-rosa.lts2012.0.i586
When I try to run hp-toolbox - it is crashed with error:
HP Linux Imaging and Printing System (ver. 3.12.6)
HP Device Manager ver. 15.0

Copyright (c) 2001-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Traceback (most recent call last):
  File "/usr/bin/hp-toolbox", line 257, in <module>
    toolbox = DevMgr5(__version__, device_uri,  None)
  File "/usr/share/hplip/ui4/devmgr5.py", line 204, in __init__
    if not utils.Is_HPLIP_older_version( installed_version,  self.user_settings.latest_available_version):
  File "/usr/share/hplip/base/utils.py", line 1838, in Is_HPLIP_older_version
    if(int(installed_array[cnt]) < int(available_array[cnt])):
ValueError: invalid literal for int() with base 10: "10a Public Release</a><br />')"


I have done urpmi  --replacepkgs hplip-hpijs hplip-hpijs-ppds hplip hplip-gui hplip-model-data but it could not to solve my problem.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 Dmitry Mikhirev 2012-12-27 13:10:35 MSK
Build lists:
i586: https://abf.rosalinux.ru/build_lists/870597
x86_64: https://abf.rosalinux.ru/build_lists/870598

Advisory:
There was a error while getting latest available version of hplip from SourceForge. As result, hp-toolbox program failed to start. The error was fixed. If you still experience problems starting hp-toolbox, remove ~/.hplip/hplip.conf file or a particular value 'latest_available_version' under 'upgrade' section in it.
Comment 2 Vladimir Potapov 2012-12-27 14:51:31 MSK
hplip-gui-3.12.6-3-rosa.lts2012.0
******************** Advisory *********************
Fix a bug with the start hp-toolbox (#1015)
***************************************************
QA Verified
Comment 3 FirstLevel 2012-12-30 19:45:55 MSK
(In reply to comment #1)
> Build lists:
> i586: https://abf.rosalinux.ru/build_lists/870597
> x86_64: https://abf.rosalinux.ru/build_lists/870598
> 
> Advisory:
> There was a error while getting latest available version of hplip from
> SourceForge. As result, hp-toolbox program failed to start. The error was
> fixed. If you still experience problems starting hp-toolbox, remove
> ~/.hplip/hplip.conf file or a particular value 'latest_available_version'
> under 'upgrade' section in it.
Deletion of ~/.hplip/hplip.conf works but it works once. After second starting of hp-toolbox I have an error and it appears until I delete ~/.hplip/hplip.conf again
Comment 4 Dmitry Mikhirev 2013-01-09 19:39:58 MSK
(In reply to comment #3)

> Deletion of ~/.hplip/hplip.conf works but it works once. After second
> starting of hp-toolbox I have an error and it appears until I delete
> ~/.hplip/hplip.conf again

Have you installed fixed packages? They are not paublished in repos yet.
Comment 5 FirstLevel 2013-01-09 21:00:34 MSK
(In reply to comment #4)
> (In reply to comment #3)
> 
> > Deletion of ~/.hplip/hplip.conf works but it works once. After second
> > starting of hp-toolbox I have an error and it appears until I delete
> > ~/.hplip/hplip.conf again
> 
> Have you installed fixed packages? They are not paublished in repos yet.

I think no. Ok. I am waiting for publishing