Bug 1010 - Could not install libhpip0 on x64 platform
: Could not install libhpip0 on x64 platform
Status: RESOLVED INVALID
Product: Desktop Bugs
Classification: ROSA Desktop
Component: Main Packages
: Marathon
: x86_64 Linux
: Normal normal
: ---
Assigned To: ROSA Linux Bugs
: ROSA Linux Bugs
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 21:43 MSD by FirstLevel
Modified: 2012-10-23 10:34 MSD (History)
1 user (show)

See Also:
RPM Package: libhpip0
ISO-related:
Bad POT generating:
Upstream:


Attachments
libhpip.png (149.01 KB, image/png)
2012-10-22 21:43 MSD, FirstLevel
Details
libhpip-64.png (125.69 KB, image/png)
2012-10-22 21:43 MSD, FirstLevel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FirstLevel 2012-10-22 21:43:26 MSD
Created attachment 782 [details]
libhpip.png

Description of problem:
Could not install libhpip0 on x64 platform, because this package is absent in repos for x64.
[root@ltsrp1-64 ~]# urpmi libhpip0
Нет пакета с названием libhpip0
See attach libhpip-64.png

Btw in x32 repos there are two version of this package. See attach libhpip.png



[root@ltsrp1-64 ~]# urpmq --list-media active
main
main updates
contrib
contrib updates
non-free
non-free updates
restricted
restricted updates
main32
main32-updates
[root@ltsrp1-64 ~]# urpmq --list-url
main http://mirror.rosalinux.com/rosa/rosa2012lts/repository/x86_64/media/main/release
main updates http://mirror.rosalinux.com/rosa/rosa2012lts/repository/x86_64/media/main/updates
contrib http://mirror.rosalinux.com/rosa/rosa2012lts/repository/x86_64/media/contrib/release
contrib updates http://mirror.rosalinux.com/rosa/rosa2012lts/repository/x86_64/media/contrib/updates
non-free http://mirror.rosalinux.com/rosa/rosa2012lts/repository/x86_64/media/non-free/release
non-free updates http://mirror.rosalinux.com/rosa/rosa2012lts/repository/x86_64/media/non-free/updates
restricted http://mirror.rosalinux.com/rosa/rosa2012lts/repository/x86_64/media/restricted/release
restricted updates http://mirror.rosalinux.com/rosa/rosa2012lts/repository/x86_64/media/restricted/updates
main32 http://mirror.yandex.ru/rosa/rosa2012lts/repository/i586/main/release
main32-updates http://mirror.yandex.ru/rosa/rosa2012lts/repository/i586/main/updates

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
Comment 1 FirstLevel 2012-10-22 21:43:42 MSD
Created attachment 783 [details]
libhpip-64.png
Comment 2 Denis Silakov 2012-10-22 23:13:58 MSD
Surely, on 64bit system you should install lib64hpip0. This naming schema is common for all libraries, not only for libhpip.
Comment 3 Denis Silakov 2012-10-23 10:00:30 MSD
A semi-joke resolution - this is not a bug, this is a feature:) (inherited from MDV library packaging policy - http://wiki.rosalab.ru/ru/index.php/Libraries_policy#Naming_on_x86_64).
Comment 4 FirstLevel 2012-10-23 10:34:06 MSD
Oops. Sorry